Neue Testversion 18.40b16

Hier diskutieren die Betatester von PhotoLine untereinander und mit den Entwicklern
User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 4001
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Neue Testversion 18.40b16

Post by Gerhard Huber »

Hallo,

es gibt wieder eine neue Testversion 18.40b16.



Windows:
www.pl32.com/beta/pl1840b16.zip


Mac OS X:
www.pl32.com/beta/plx1840b16.zip


Neues:
- die Fehler aus der Beta 15 behoben :-)

Mac OS:
neu signiert, sollte jetzt auf allen OS X Versionen funktionieren.



diverse kleinere Verbesserungen und Fehlerbehebungen





Gerhard Huber [Computerinsel GmbH]
support@pl32.de - www.pl32.de
User avatar
gmhofmann
Betatester
Posts: 735
Joined: Tue 19 Nov 2002 17:22
Location: Heilbronx, Deutschland

Re: Neue Testversion 18.40b16

Post by gmhofmann »

Ich kann wieder Ebenen anlegen, juchei!
User avatar
photoken
Mitglied
Posts: 2162
Joined: Sat 28 Sep 2013 01:25

Re: Neue Testversion 18.40b16

Post by photoken »

Looking good!

New Layer works. :mrgreen:

Bugs fixed in 18.40b15 (3D Body, Batch Conversion) as well as enhancements (HDRMerge floating-point DNG image support) continue to work. :D
Ken
Yes, I think it can be eeeeeasily done....
Just take everything out on Highway 61.
User avatar
photoken
Mitglied
Posts: 2162
Joined: Sat 28 Sep 2013 01:25

Tooltip content needed (English)

Post by photoken »

Win7 x64 SP1
PL18.40b16 x64

When the Curve Creation tool is used, the tooltip for its "Create in New Layer" needs to have content (not just the listing of the keyboard key):
curve creation settings.png
You do not have the required permissions to view the files attached to this post.
Ken
Yes, I think it can be eeeeeasily done....
Just take everything out on Highway 61.
bkh
Betatester
Posts: 3661
Joined: Thu 26 Nov 2009 22:59

Re: Neue Testversion 18.40b16

Post by bkh »

Die Abstürze beim Öffnen-/Speichern-Dialog sind fast weg: wenn ich dort mein Home-Verzeichnis anwähle, gibt's immer noch einen Crash – alle anderen Favoriten funktionieren. Seltsam!

L.G.

Burkhard.
Martin Huber
Entwickler
Entwickler
Posts: 3950
Joined: Tue 19 Nov 2002 15:49

Re: Neue Testversion 18.40b16

Post by Martin Huber »

bkh wrote:Die Abstürze beim Öffnen-/Speichern-Dialog sind fast weg: wenn ich dort mein Home-Verzeichnis anwähle, gibt's immer noch einen Crash – alle anderen Favoriten funktionieren. Seltsam!
Ja. Bei mir tritt das Problem nicht auf. Schick bitte mal den Crash-Report.

Du hast 10.9.4? Hast du irgendwas besonderes im Home-Verzeichnis?

Martin
bkh
Betatester
Posts: 3661
Joined: Thu 26 Nov 2009 22:59

Re: Neue Testversion 18.40b16

Post by bkh »

Martin Huber wrote: Ja. Bei mir tritt das Problem nicht auf. Schick bitte mal den Crash-Report.
Ist unterwegs (an support@pl32.de).
Martin Huber wrote: Du hast 10.9.4?
Ja.
Martin Huber wrote: Hast du irgendwas besonderes im Home-Verzeichnis?
Ja, habe eben mal probiert: es liegt an Aliases auf Ordner im Netzwerk – wenn ich die aufs Desktop verschiebe, stürzt PL nicht mehr bei meinem Home-Verzeichnis ab, dafür aber beim Wechsel aufs Desktop.

L.G.

Burkhard.
Martin Huber
Entwickler
Entwickler
Posts: 3950
Joined: Tue 19 Nov 2002 15:49

Re: Neue Testversion 18.40b16

Post by Martin Huber »

bkh wrote:
Martin Huber wrote: Ja. Bei mir tritt das Problem nicht auf. Schick bitte mal den Crash-Report.
Ist unterwegs (an support@pl32.de).
Martin Huber wrote: Hast du irgendwas besonderes im Home-Verzeichnis?
Ja, habe eben mal probiert: es liegt an Aliases auf Ordner im Netzwerk – wenn ich die aufs Desktop verschiebe, stürzt PL nicht mehr bei meinem Home-Verzeichnis ab, dafür aber beim Wechsel aufs Desktop.
So wie der Report aussieht, stürzt PhotoLine nicht ab, sondern PhotoLine versucht den Alias aufzulösen, und die entsprechende Betriebssystemroutine bleibt beim Versuch, das Laufwerk für den Alias zu mounten, hängen und liefert nie ein Ergebnis zurück.

Dummerweise kann ich das Problem bei mir nicht nachvollziehen. Wenn ich einen Alias anlege, der auf einen Ordner auf meinem Windows-Rechner weist, und dann Windows beende, funktioniert bei mir das Verzeichnis mit dem Alias weiterhin problemlos.

Kannst du genaueres zu dem Alias schreiben? Benötigt er Benutzername und Passwort? Ist das Netzlaufwerk momentan verfügbar?

Martin
bkh
Betatester
Posts: 3661
Joined: Thu 26 Nov 2009 22:59

Re: Neue Testversion 18.40b16

Post by bkh »

Martin Huber wrote:So wie der Report aussieht, stürzt PhotoLine nicht ab, sondern PhotoLine versucht den Alias aufzulösen, und die entsprechende Betriebssystemroutine bleibt beim Versuch, das Laufwerk für den Alias zu mounten, hängen und liefert nie ein Ergebnis zurück.
Ja, stimmt, ist kein Absturz (segfault), sondern ich muss PL mit Force Quit beenden oder das Netzwerklaufwerk von Hand anmelden (s. u.)
Martin Huber wrote:Kannst du genaueres zu dem Alias schreiben? Benötigt er Benutzername und Passwort? Ist das Netzlaufwerk momentan verfügbar?
Ja, ist ein weiterer Mac im lokalen Netzwerk (also afp-Protokoll) und benötigt Benutzername und Passwort. Natürlich enthält der Dateipfad Leerzeichen und der Benutzername einen Umlaut … Jedenfalls: wenn das Netzwerklaufwerk gemounted ist, bevor ich in den Öffnen-Dialog gehe, ist alles ok. Ist es nicht gemounted oder gar keine Netzwerkverbindung da, dann hängt sich PL auf, und zwar bis ich das Laufwerk anmelde.

Ach ja, habe eben nochmal in die Konsole geschaut: dort erscheint immer wieder die Meldung
07/08/14 22:12:15,255 NetAuthSysAgent[49543]: ERROR: AFP_OpenSession - Login failed with 80
07/08/14 22:12:15,257 PhotoLine[49400]: /Users/Burkhard/<alias name>: The operation couldn’t be completed. (OSStatus error 80.)

statt <alias name> tauchen die Dateinamen der Aliasse auf.

Mit einem Symlink auf eine WebDAV-Platte gibt es diese Probleme nicht. Windows-Rechner habe ich nicht im Netzwerk, aber ich kann evtl. mal am Wochenende einen Mac auf smb-filesharing umstellen.

L.G.

Burkhard.
bkh
Betatester
Posts: 3661
Joined: Thu 26 Nov 2009 22:59

Re: Neue Testversion 18.40b16

Post by bkh »

Noch 'ne Ergänzung: wenn der Alias sich auf das ganze Netzswerklaufwerk bezieht, scheint ebenfalls alles zu funktionieren, nur bei einem Alias für einen Ordner oder eine Datei auf einem Netzwerklaufwerk habe ich Probleme.

L.G.

Burkhard.
Martin Huber
Entwickler
Entwickler
Posts: 3950
Joined: Tue 19 Nov 2002 15:49

Re: Neue Testversion 18.40b16

Post by Martin Huber »

bkh wrote:Ja, ist ein weiterer Mac im lokalen Netzwerk (also afp-Protokoll) und benötigt Benutzername und Passwort. Natürlich enthält der Dateipfad Leerzeichen und der Benutzername einen Umlaut … Jedenfalls: wenn das Netzwerklaufwerk gemounted ist, bevor ich in den Öffnen-Dialog gehe, ist alles ok. Ist es nicht gemounted oder gar keine Netzwerkverbindung da, dann hängt sich PL auf, und zwar bis ich das Laufwerk anmelde.
Ich kann das Problem immer noch nicht nachvollziehen.
Ich habe nun auf einem zweiten Mac einen neuen Benutzer mit Passwort angelegt, dort im Home-Verzeichnis im Bilder-Ordner einen Ordner mit Namen "Meine Testbilderäöü" angelegt, und auf dem Haupt-Mac in meinem Home-Verzeichnis einen Alias auf "Meine Testbilderäöü" erzeugt. Dann habe ich im Finder den gemounteten Test-User ausgeworfen (der Rechner mit dem Test-User läuft aber noch). Wenn ich nun PhotoLine starte und im Open-Dialog auf mein Home-Verzeichnis wechsele, dann geht das problemlos.
Ist bei dir Konstellation anders?
bkh wrote:Ach ja, habe eben nochmal in die Konsole geschaut: dort erscheint immer wieder die Meldung
07/08/14 22:12:15,255 NetAuthSysAgent[49543]: ERROR: AFP_OpenSession - Login failed with 80
07/08/14 22:12:15,257 PhotoLine[49400]: /Users/Burkhard/<alias name>: The operation couldn’t be completed. (OSStatus error 80.)

statt <alias name> tauchen die Dateinamen der Aliasse auf.
Die Fehlermeldungen sind ja auch richtig, da die Anmeldung nicht funktioniert, aber warum bleibt die Funktion dann hängen? Kommt für einen der Aliasse keine Meldung? Und wenn ja: Gibt es bei dem eine Besonderheit?

Du hast mehrere Aliasse in deinem Verzeichnis: Tritt das Problem auch auf, wenn du nur einen hast?

Nachtrag: Ich habe jetzt den zweiten Mac abgeschaltet, und das alles nochmal ausprobiert. Nun habe ich beim Wechsel auf das Home-Verzeichnis ein Wartezeit von ca. 30 Sekunden. Wenn du mehrere Aliasse hast, wird das wahrscheinlich entsprechend mehr. Und jedesmal, wenn der Open-Dialog den Fokus verliert, beginnt die Wartezeit von vorne.
Ganz schlimm wird es, wenn ich auf den Alias klicke. In dem Fall scheint er ewig zu kreisen mit dem immer wieder auftauchenden Fehlerdialog "Beim Verbinden mit dem Server Blablabla ist ein Fehler aufgetreten". In diesem Fall ist PhotoLine aber gar nicht beteiligt, sondern es handelt sich um ein Mac OS-internes Problem.

Martin
Torsten
Mitglied
Posts: 551
Joined: Mon 28 Nov 2011 09:27

Re: Neue Testversion 18.40b16

Post by Torsten »

Nach langer Zeit habe ich mal wieder versucht eine Beta Version, in diesem Fall die aktuellste 18.40b16 zu installieren.

Ich habe mir auch extra zwei Ordner im Programme Verzeichnis meines Mac angelegt, einmal PhotoLine und ein mal PhotoLine Beta. Darin habe ich jeweils die Programme installiert. Wenn ich nun in der Beta Version versuche die Bildübersicht zu öffnen, dann kommt der Beachball und PhotoLine bleibt hängen und reagiert nicht mehr. Ich muss es dann über Programme sofort beenden killen. Bei der normalen stabilen Version 18.02 läuft alles bestens.

Auch seltsam das die Bildübersicht in der Beta-Version eine ganz andere Baumstruktur aufweist, quasi fast gar keine…

Torsten
You do not have the required permissions to view the files attached to this post.
Martin Huber
Entwickler
Entwickler
Posts: 3950
Joined: Tue 19 Nov 2002 15:49

Re: Neue Testversion 18.40b16

Post by Martin Huber »

Torsten wrote:Nach langer Zeit habe ich mal wieder versucht eine Beta Version, in diesem Fall die aktuellste 18.40b16 zu installieren.

Ich habe mir auch extra zwei Ordner im Programme Verzeichnis meines Mac angelegt, einmal PhotoLine und ein mal PhotoLine Beta. Darin habe ich jeweils die Programme installiert. Wenn ich nun in der Beta Version versuche die Bildübersicht zu öffnen, dann kommt der Beachball und PhotoLine bleibt hängen und reagiert nicht mehr. Ich muss es dann über Programme sofort beenden killen. Bei der normalen stabilen Version 18.02 läuft alles bestens.
Wie lange hast du bis zum "Sofort beenden" gewartet? Zeigt die Konsole.app Meldungen an? Was ist der angezeigte Pfad in der Version 18.02? Ist das ein Ordner auf dem Bootlaufwerk oder auf einem anderen Laufwerk (im Stil von "/Volumes/Laufwerk/...") oder was ganz was anderes?
Torsten wrote:Auch seltsam das die Bildübersicht in der Beta-Version eine ganz andere Baumstruktur aufweist, quasi fast gar keine…
Was fehlt denn?

Martin
Torsten
Mitglied
Posts: 551
Joined: Mon 28 Nov 2011 09:27

Re: Neue Testversion 18.40b16

Post by Torsten »

Ich habe da so ca. 3 - 5 min gewartet, jetzt lasse ich es mal laufen. Im Anhang 2 Screenshots von den Ordnerstruktur-Bäumen aus der Bildvorschau. Die Dateien sind entsprechend benannt.

Gruß Torsten
You do not have the required permissions to view the files attached to this post.
Torsten
Mitglied
Posts: 551
Joined: Mon 28 Nov 2011 09:27

Re: Neue Testversion 18.40b16

Post by Torsten »

So jetzt habe ich das nach ca. 30 Minuten abgebrochen, die Konsole dokumentiert nur meinen Abbruch...

Es grüßt Torsten