[Bug] Photoline doesn't save or crashes before saving

Hier diskutieren die Betatester von PhotoLine untereinander und mit den Entwicklern
ZoltanE
Mitglied
Posts: 61
Joined: Sat 11 Oct 2014 16:39

[Bug] Photoline doesn't save or crashes before saving

Post by ZoltanE »

EDIT: Scratch that, the bug is related to this particular file. Still investigating.

EDIT2: It seems that it was caused by having two instances of Photoline running, one
started from the start menu while the other started by double clicking on a .pld file. The
weird thing was that I did not realize that two of them are running until I checked the
task manager: the taskbar showed a single icon (no window stacking). So my guess is
that save failed because the other, hidden instance was locking the file or something.
A reboot helped.

I'll keep an eye out for this issue until I could provide a more precise description.
ZoltanE
Mitglied
Posts: 61
Joined: Sat 11 Oct 2014 16:39

Re: [Bug] Photoline doesn't save or crashes before saving

Post by ZoltanE »

Okay it seems to be related to this file:
http://www.zspline.net/temp/Doors.pld

When I enable visibility on the red vector layer seen here...
http://zspline.net/temp/Clipboard%20Ima ... 820%29.png
..then saving stops working: Ctrl+S doesn't perform the save just makes the cursor
look like an hourglass. (The UI keeps working.)
"Save As..." makes PhotoLine stop responding. Its process gets stuck,
has to be killed from task manager.

I was able to reproduce this 100% of the time with that file.
mwenz
Mitglied
Posts: 122
Joined: Fri 13 May 2011 23:50

Re: [Bug] Photoline doesn't save or crashes before saving

Post by mwenz »

OK. See the screen shot. Are you certain you linked to the file that causes the problem?

When I open your file, the layers are different. I can do anything in this file from making the red layer visiable, making adjustments, etc etc and it doesn't exhibit any issues.

Mike
capture-002141.png
You do not have the required permissions to view the files attached to this post.
ZoltanE
Mitglied
Posts: 61
Joined: Sat 11 Oct 2014 16:39

Re: [Bug] Photoline doesn't save or crashes before saving

Post by ZoltanE »

You are looking at the wrong group: open the orange one, called "Color".
mwenz
Mitglied
Posts: 122
Joined: Fri 13 May 2011 23:50

Re: [Bug] Photoline doesn't save or crashes before saving

Post by mwenz »

Opened file...hopefully the correct layer this time. Saved as yet a new version.
capture-002142.jpg
Made a change to the red vector, saved to another version.
capture-002143.jpg

In both instances, I was able to overwrite the original file.

Mike
You do not have the required permissions to view the files attached to this post.
User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 4001
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: [Bug] Photoline doesn't save or crashes before saving

Post by Gerhard Huber »

I tested this here with version 18.52 of PhotoLine and see no problem. Which version of PhotoLine did you use?

Gerhard
ZoltanE
Mitglied
Posts: 61
Joined: Sat 11 Oct 2014 16:39

Re: [Bug] Photoline doesn't save or crashes before saving

Post by ZoltanE »

Oh I totally forgot that I'm on 18.90B2. I've just installed 18.51 and indeed everything
seems to be fine there. Sorry for the scare. :) Thank you for the quick response!
User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 4001
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: [Bug] Photoline doesn't save or crashes before saving

Post by Gerhard Huber »

Moved to the beta forum, since the problem occurs in the beta version only and the title is very provocative.
The problem is known already and will be fixed in the next beta.

Gerhard