Neue Testversion 18.90b10

Hier diskutieren die Betatester von PhotoLine untereinander und mit den Entwicklern
User avatar
photoken
Mitglied
Posts: 2162
Joined: Sat 28 Sep 2013 01:25

Re: Bug: Color fringe remains after extracting a selection

Post by photoken »

Martin Huber wrote: Creating the correct mask values is the hard part. While it is straightforward in synthetic images (like your example), the straightforward solution doesn't work well with photos. And the opposite is true, too: Solutions, that work good with photos are not that good with synthetic images, because with photos we need to use some kind of fuzziness, that is harmful with synthetic images.
At the moment I don't know how to resolve that conflict.
I think I may have an answer -- PL's beta already has the tool to resolve the colour fringing when a selection is extracted from a synthetic image: the Color to Transparency tool.

In both Case #1 and Case #2, if I use the Color to Transparency tool on the extracted layer by using the eyedropper to select a remaining fringe pixel and then adjusting the sliders, the colour fringe is successfully removed. No further masking is necessary.

So, it would seem that only a solution that works good with photos is necessary. Whether it's an enhancement to the masking tools of the Border Matting Tool or an "aggressiveness" slider for the "Remove Color Border" option of the Extract Selection option/tool is an open question.
Ken
Yes, I think it can be eeeeeasily done....
Just take everything out on Highway 61.
User avatar
Herbert123
Mitglied
Posts: 2018
Joined: Sat 12 May 2012 21:38

Re: Neue Testversion 18.90b10

Post by Herbert123 »

Yes, I have used the color to transparency adjustment layer for defringing as well. As a matter of fact, multiple of these can be stacked for a lot of precise control.
/*---------------------------------------------*/
System: Win10 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), Nvidia GTX1080 8GB, Revodrive X2 240gb, e-mu 1820, 2XSamsung SA850 (2560*1440) and 1XHP2408H 1920*1200 portrait
User avatar
Herbert123
Mitglied
Posts: 2018
Joined: Sat 12 May 2012 21:38

Re: Neue Testversion 18.90b10

Post by Herbert123 »

There is a bug related to 32bit layered files and anti-aliasing turned on under circumstances.

See this thread: http://www.pl32.com/forum3/viewtopic.php?f=3&t=4585

When zoomed out random black blocks appear. Turning off anti-aliasing (/-button) fixes this. The problem also disappears when the background layer is converted to 16 or 8 bit per channel.
/*---------------------------------------------*/
System: Win10 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), Nvidia GTX1080 8GB, Revodrive X2 240gb, e-mu 1820, 2XSamsung SA850 (2560*1440) and 1XHP2408H 1920*1200 portrait
User avatar
Herbert123
Mitglied
Posts: 2018
Joined: Sat 12 May 2012 21:38

Re: Neue Testversion 18.90b10

Post by Herbert123 »

By the way, when was that new "Lasso from Curves and Lines" tool implemented?! Just found it today when I needed to do some quick selection edge editing, and it's a brilliant addition!

Thanks, saved me a lot of time!

*EDIT* And many thanks for the awesome addition of path alignment (inside, outside, center) - it works really well. I had not expected that option at all! Also very nice to see it works with variable width strokes.

At this point the overall usability of the stroke settings would be improved if that dialog would be a non-model one (with all the settings, including the stroke width curve and , similar to the brush settings panel.

It could look like this :D (also notice the options for a soft stroke and curve control for the arrow... :wink: )
stroke editor.jpg
You do not have the required permissions to view the files attached to this post.
/*---------------------------------------------*/
System: Win10 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), Nvidia GTX1080 8GB, Revodrive X2 240gb, e-mu 1820, 2XSamsung SA850 (2560*1440) and 1XHP2408H 1920*1200 portrait
arnold_s
Mitglied
Posts: 66
Joined: Sun 04 Oct 2009 02:36

Re: Neue Testversion 18.90b10

Post by arnold_s »

Herbert123 wrote: At this point the overall usability of the stroke settings would be improved if that dialog would be a non-model one (with all the settings, including the stroke width curve and , similar to the brush settings panel.
I think, "modal" is meant. It's also my biggest issue with this -other than that- great feature.
E.g. you can copy to the curve-list, but you can't use the opposite direction.
User avatar
Herbert123
Mitglied
Posts: 2018
Joined: Sat 12 May 2012 21:38

Re: Neue Testversion 18.90b10

Post by Herbert123 »

arnold_s wrote:
Herbert123 wrote: At this point the overall usability of the stroke settings would be improved if that dialog would be a non-model one (with all the settings, including the stroke width curve and , similar to the brush settings panel.
I think, "modal" is meant. It's also my biggest issue with this -other than that- great feature.
E.g. you can copy to the curve-list, but you can't use the opposite direction.
No, I really meant "non-modal" or "modeless". See Wikipedia:
http://en.wikipedia.org/wiki/Dialog_box#Modeless

The stroke editor should ideally behave like the brush editor panel, or the layer panel. Select a path, then start changing the stroke parameters. The current workflow is very inefficient when a lot of vector fine-tuning and drawing is done, which is probably the reason why every other vector editor keeps these options around in a floating non-modal (modeless) panel for easy and quick access.
/*---------------------------------------------*/
System: Win10 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), Nvidia GTX1080 8GB, Revodrive X2 240gb, e-mu 1820, 2XSamsung SA850 (2560*1440) and 1XHP2408H 1920*1200 portrait
arnold_s
Mitglied
Posts: 66
Joined: Sun 04 Oct 2009 02:36

Re: Neue Testversion 18.90b10

Post by arnold_s »

Herbert123 wrote:
arnold_s wrote:
Herbert123 wrote: No, I really meant "non-modal" or "modeless".
Yeah, that's what i meant.
I only referred to the typo.
User avatar
Herbert123
Mitglied
Posts: 2018
Joined: Sat 12 May 2012 21:38

Re: Neue Testversion 18.90b10

Post by Herbert123 »

arnold_s wrote: I only referred to the typo.
Oops, my oversight! :-)
/*---------------------------------------------*/
System: Win10 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), Nvidia GTX1080 8GB, Revodrive X2 240gb, e-mu 1820, 2XSamsung SA850 (2560*1440) and 1XHP2408H 1920*1200 portrait