I found a strange bug

Hier diskutieren die Betatester von PhotoLine untereinander und mit den Entwicklern
jw2004
Mitglied
Posts: 86
Joined: Sun 15 Mar 2015 05:59

I found a strange bug

Post by jw2004 »

If I work as below steps, PL program exit.
1. Create a shape (eg: circle);
2. Press ctrl+c and ctrl+v to copy it;
3. Press shift and drag to move horizontal;
4. Press the fill color button to show the color dialog;
5. Click to choose color.

Then the program crash.
But the 3rd step I make a slightly change, for ex, don't press SHIFT, move it free, program will not crash, or do any other operation, then operator continue from 3rd step, PL will not crash.

Summary: PL crash when you operate from 1 to 5 step strictly. Even the minimum differency operation make PL not crash.
PL19 x64 win7 64
jw2004
Mitglied
Posts: 86
Joined: Sun 15 Mar 2015 05:59

Re: I found a strange bug

Post by jw2004 »

I found PL crash when I choose fill color a lot of scenes.
I use PL 18.90b12 x64 version
PL19 x64 win7 64
bkh
Betatester
Posts: 3661
Joined: Thu 26 Nov 2009 22:59

Re: I found a strange bug

Post by bkh »

No problems here. What OS do you use? Does this happen with the release version of PL? (Bugs in the beta version should be reported to the beta testers forum, not here, btw.). Did you try starting PL with a PhotoLineSettings folder, to make sure you aren't using a corrupt colour palette or something like that?

Cheers

Burkhard.
User avatar
Hoogo
Betatester
Posts: 3914
Joined: Sun 03 Jul 2005 13:35
Location: Mülheim/Ruhr

Re: I found a strange bug

Post by Hoogo »

Same here, no problem. Btw: What "fill color button"? Opening the dropdown in the tool palette, double-clicking it, or selecting the color using the attributes palette?
----------------
Herr Doktor, ich bin mir ganz sicher, ich habe Atom! /Doctor, doctor, I'm sure, I've got atoms!
jw2004
Mitglied
Posts: 86
Joined: Sun 15 Mar 2015 05:59

Re: I found a strange bug

Post by jw2004 »

I use PL 18.90B12 64bit in Windows 7 64bit

PL crash frequently when click the fill color combobox and try to select color.

You can download my test video:

http://pan.baidu.com/s/1dDrRhnV
PL19 x64 win7 64
User avatar
photoken
Mitglied
Posts: 2162
Joined: Sat 28 Sep 2013 01:25

Re: I found a strange bug

Post by photoken »

Same here -- No problem on Win7 x64 SP1, with PL 18.90 b12 x64.

Never have any problems choosing the fill colour, either, regardless of the situation.
Ken
Yes, I think it can be eeeeeasily done....
Just take everything out on Highway 61.