Neue Testversion 19.00rc2

Hier diskutieren die Betatester von PhotoLine untereinander und mit den Entwicklern
shane
Mitglied
Posts: 31
Joined: Sat 18 May 2013 05:00
Location: Michigan USA

Re: Neue Testversion 19.00rc2

Post by shane »

Hoogo wrote:
shane wrote:The last two betas the splash screen stops at 7 and will not go away.
I am still having problems with the undo / redo message staying on screen but cannot reproduce it consistently.
Does this mean that PL is running fine, but you have to work around the splash screen?? Or is this also some kind of redraw problem, and the splash screen goes away once you open a picture?
Splash screen will not go away. It will stay on screen until I close the application. Opening files creating new files etc. has no effect it still remains. I just installed 19rc2 on my home laptop and everything works as expected. Strange, maybe I will try deleting my preferences and see it that has any effect.
-Shane
User avatar
Hoogo
Betatester
Posts: 3890
Joined: Sun 03 Jul 2005 13:35
Location: Mülheim/Ruhr

Re: Neue Testversion 19.00rc2

Post by Hoogo »

shane wrote:Splash screen will not go away. It will stay on screen until I close the application. Opening files creating new files etc. has no effect it still remains. I just installed 19rc2 on my home laptop and everything works as expected. Strange, maybe I will try deleting my preferences and see it that has any effect.
If you run PL in the mode for USB sticks, you could even back up your preferences and see if they were really the cause.
----------------
Herr Doktor, ich bin mir ganz sicher, ich habe Atom! /Doctor, doctor, I'm sure, I've got atoms!
User avatar
Christopher
Mitglied
Posts: 215
Joined: Sat 25 May 2013 14:34
Location: Riedstadt

Re: Neue Testversion 19.00rc2

Post by Christopher »

Hallo zusammen,

seit der 19.00rc2 habe ich das kleine Problem, das PL nach dem Start recht lange braucht, bis auf Eingaben reagiert wird, irgendwie wird hier ständig auf die Platte zugegriffen.
Dies ist mir gestern schon auf meinem PC aufgefallen, nun habe ich heute auf meinem Notebook noch die rc1 gehabt, damit getestet ist o.k. danach die rc2 installiert, gleiches verhalten wie auf dem PC.
Irgendetwas ist hier anders, gibt es weitere Infos die ich liefern kann (Trace, Configs usw. ) ?

Ich verwende Windows 8.1/64 und 7/64 und von PL ebenfalls die 64Bit Version
Gruss Christopher

IMatch zur Bilderverwaltung, Capture One und DxO PhotoLab
als RAW-Converter und PhotoLine (x64) zur Bildbearbeitung.
Es geht auch sehr gut ohne Abobe Produkte und Adobe's Abomodell.
Betriebssystem Windows 10
JulianZI
Mitglied
Posts: 733
Joined: Tue 19 Dec 2006 19:54
Location: München

Re: Neue Testversion 19.00rc2

Post by JulianZI »

Startbildschirm - sehr schön übrigens - wird immer noch als Bitmap hochskaliert.

Seid Ihr sicher, dass ihr da nicht irgendwo die Auflösung abfragt? Die Window SIZE müsste exakt der W/H der PNG entsprechen.

Da dies sowieso eine Vektorgrafik ist, könnte man an dieser Stelle nicht auch die PL32 Engine anwerfen und in ein Fenster zeichnen lassen. Dann könnten die V3ektor Elemente auch nacheinender erscheinen, ein Objektiv, zweites, PL! ...
Die PLD kann man ja ganz gut als Resource einbinden.

Ist Gimmik, wird aber heutzutage anscheinend bei einem Grafikprogram erwartet.
Andre
Mitglied
Posts: 80
Joined: Sat 29 Sep 2007 14:08

Re: Neue Testversion 19.00rc2

Post by Andre »

Bitte zerreißt mich jetzt nicht wegen Erbsenzählerei.
Beim neuen Splashscreen fällt mir auf, dass auf dem einen Objektiv "Photoline 18" steht.

Ich nehme an das wird aus Konsistenzgründen noch in "Photoline 19" geändert?
shane
Mitglied
Posts: 31
Joined: Sat 18 May 2013 05:00
Location: Michigan USA

Re: Neue Testversion 19.00rc2

Post by shane »

I think I found the problem or at least can reproduce the splash screen that will not go away. PL was opening in 32bit mode, when I switched it to 64bit the splash screen will now continue the count-down and disappear. Switching it back to 32bit will cause the splash screen to freeze.
-Shane
bkh
Betatester
Posts: 3661
Joined: Thu 26 Nov 2009 22:59

Re: Neue Testversion 19.00rc2

Post by bkh »

shane wrote:I think I found the problem or at least can reproduce the splash screen that will not go away. PL was opening in 32bit mode, when I switched it to 64bit the splash screen will now continue the count-down and disappear. Switching it back to 32bit will cause the splash screen to freeze.
I can confirm the problem in the 32 bit version. Mine doesn't even start counting down.

Cheers

Burkhard.
bkh
Betatester
Posts: 3661
Joined: Thu 26 Nov 2009 22:59

Re: Neue Testversion 19.00rc2

Post by bkh »

I have found one instance of a reproducible redraw problem.

1) If, in the attached document, you turn off "clip" for the isolated group acting as a layer mask, then turn it on again (by shift-clicking in the appropriate box in the layer panel), the change doesn't show in the main window (until you zoom etc.).

2) If you move one of the layers in the isolated group around quickly, there are redraw artefacts as well.

I can reproduce both problems in 18.53 as well, so maybe these are unrelated to the redraw problem reported earlier.

Cheers

Burkhard.
You do not have the required permissions to view the files attached to this post.
Martin Huber
Entwickler
Entwickler
Posts: 3942
Joined: Tue 19 Nov 2002 15:49

Re: Neue Testversion 19.00rc2

Post by Martin Huber »

bkh wrote:
shane wrote:I think I found the problem or at least can reproduce the splash screen that will not go away. PL was opening in 32bit mode, when I switched it to 64bit the splash screen will now continue the count-down and disappear. Switching it back to 32bit will cause the splash screen to freeze.
I can confirm the problem in the 32 bit version. Mine doesn't even start counting down.
On Mac OS in 32 Bit time measurement inside PhotoLine isn't working correctly. I will fix that.
In the meantime I recommend not to use the 32 bit version on Mac OS.

Martin
User avatar
Herbert123
Mitglied
Posts: 2009
Joined: Sat 12 May 2012 21:38

Re: Neue Testversion 19.00rc2

Post by Herbert123 »

The stamp tool is missing the new channel/blend mode option - this would be extremely useful, though, especially with the stamp tool.
/*---------------------------------------------*/
System: Win10 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), Nvidia GTX1080 8GB, Revodrive X2 240gb, e-mu 1820, 2XSamsung SA850 (2560*1440) and 1XHP2408H 1920*1200 portrait
User avatar
photoken
Mitglied
Posts: 2162
Joined: Sat 28 Sep 2013 01:25

Suggestion for the new splash screen

Post by photoken »

This customization fine-tunes the text on the top line, and makes use of my variation on the PL logo:
http://www.pl32.com/forum3/viewtopic.ph ... 687#p34652
PhotoLine.jpg
Here's the PLD file:
PhotoLine.pld
If you want to use it in your copy of PL, replace the file in your PhotoLine /hlp directory with this one.

Enjoy!
You do not have the required permissions to view the files attached to this post.
Ken
Yes, I think it can be eeeeeasily done....
Just take everything out on Highway 61.
User avatar
Herbert123
Mitglied
Posts: 2009
Joined: Sat 12 May 2012 21:38

Re: Neue Testversion 19.00rc2

Post by Herbert123 »

When I add a liquify layer, and distort an image, and zoom in and out, colours change. This also happens when zoomed in and when I use the rotate view tool. It seems that it has something to do with the image being cut off by the screen. When I am zoomed out, and the entire image is shown, it works as espected.

It reminds me of the classic Amiga colour cycle effects when you apply this to an image with a rainbow effect ;-P
/*---------------------------------------------*/
System: Win10 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), Nvidia GTX1080 8GB, Revodrive X2 240gb, e-mu 1820, 2XSamsung SA850 (2560*1440) and 1XHP2408H 1920*1200 portrait
User avatar
Herbert123
Mitglied
Posts: 2009
Joined: Sat 12 May 2012 21:38

Re: External program with "None" as image type

Post by Herbert123 »

photoken wrote:Getting closer!

I can successfully launch an external program with an image type of "None", but only if there is an image open in PL. If PL does not have an image open, those external programs do not launch -- no error message, nothing happens.

This is an exciting feature! :D It's really sweet to be able to use XnView as my file browser, and to do HDRMerges and panorama stitching almost as if they were within PL. Should also be good for focus stacking apps, too.

This can make PL an effective "image processing hub" for all types of graphics work! :mrgreen:
If I may ask, what does the "None" option do?
/*---------------------------------------------*/
System: Win10 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), Nvidia GTX1080 8GB, Revodrive X2 240gb, e-mu 1820, 2XSamsung SA850 (2560*1440) and 1XHP2408H 1920*1200 portrait
User avatar
Herbert123
Mitglied
Posts: 2009
Joined: Sat 12 May 2012 21:38

Re: Neue Testversion 19.00rc2

Post by Herbert123 »

The new splash is a big improvement over the old one. And it could be improved further!
If I may suggest a couple of changes to the splash?

There are a couple of grammatical tidbits that can be improved, and placing the texts all around the main graphic is a classic design mistake (the "doughnut" effect, as is is called). Allow for negative space so that the design can breathe more.

Visual hierarchy is also important. The current version leads the eyes to four different elements, and confuses the eyes: where to look first? I added more hierarchy, grouping, and improved the spacing, leading, and so on. I also turned on anti-aliasing for the info text, which improves the type (I avoided doing this with the shareware message, though ;-).

Now, I do understand that the non-registered version should look "uglier" than the registered version - and the registered version can be improved quite a bit by repositioning some of the elements, and allow those elements to 'breathe".

"Version" ought to be lowercase (no capital).

I used Ubuntu as a font to style the Photoline heading, since the 'L" reminds us more of the PL logo, and the font is open source (and can be included with the installation). It also places far more importance on the name of the application, which I feel is important within this context.

Instead of a reddish coloured day counter, I applied yellow. Yellow is the first colour our brain notices - red being the last one to be noticed. It is also complementary to the blue, and this colour change forces users with a non-registered version to take note.

The result of these changes is that the splash looks more refined, and the visual hierarchy is much improved. It is no longer focused on that graphic in the center alone, and the message reads much better.

(original pld : http://www.estructor.altervista.org/lin ... splash.pld )
PS the jpg compression and scaling on this forum reduces the quality - make certain to check out the original file for best quality.
splash-no-reg.jpg
splash-reg.jpg
Compare with the original:
PhotoLine.jpg
You do not have the required permissions to view the files attached to this post.
/*---------------------------------------------*/
System: Win10 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), Nvidia GTX1080 8GB, Revodrive X2 240gb, e-mu 1820, 2XSamsung SA850 (2560*1440) and 1XHP2408H 1920*1200 portrait
User avatar
photoken
Mitglied
Posts: 2162
Joined: Sat 28 Sep 2013 01:25

Re: External program with "None" as image type

Post by photoken »

Herbert123 wrote: If I may ask, what does the "None" option do?
It opens the external program without supplying an image to it.
Ken
Yes, I think it can be eeeeeasily done....
Just take everything out on Highway 61.