Kurven und Vektorpunkte - Bearbeitung hat spürbare Verzögerung (auch Gradation)

Moderator: Hoogo

Ashcraaft
Mitglied
Posts: 474
Joined: Fri 26 Nov 2010 10:39
Location: Kempen

Kurven und Vektorpunkte - Bearbeitung hat spürbare Verzögerung (auch Gradation)

Post by Ashcraaft » Wed 17 Apr 2019 10:58

Ergänzend zu meinen Vorschlägen zur Pfadbearbeitung hier noch ein Problem, dem ich lieber einen eigenen Thread widme. Ist etwas schwer zu beschreiben aber ich versuche es trotzdem mal…

Ich habe das Gefühl, dass der "Aktivitätsfokus" des Werkzeugs immer ein paar Millisekunden zu lang auf dem Werkzeug oder dem ausgewählten Pfadpunkt verbleibt. Dies passiert typischerweise, wenn ich während der Pfadbearbeitung auf die Verschiebehand wechsele, um den Bildausschnitt zu verschieben.
Dadurch kommt es häufig vor, dass ich ungewollt den noch aktiven Punkt verschiebe, anstatt den Bildausschnitt.

Das selbe stelle ich ebenfalls beim Modifizieren von Gradationskurven fest.
Oftmals "verreiße" ich so eine Kurve auf ungewollte Extremwerte, weil der Anfasser irgendwie noch "festhängt".

Mein Mac ist noch recht jung (iMac Retina 5K, 27-inch, 2017, 16GB RAM) und ansonsten reagiert Photoline auch recht fix. Ich kann mir deshalb nicht vorstellen, dass es am Rechner liegt :roll:

Hat das sonst schon mal jemand bemerkt und gibt es überhaupt einen zeitlichen Spielraum für den Werkzeugwechsel?
Bitte besuche & teile PhotoLine auf folgenden Seiten:
PhotoLine bei Facebook | YouTube

Danke, Sascha Ballweg
(Photoline-Nutzung: Mac OS-X & Windows 7)

Martin Huber
Entwickler
Entwickler
Posts: 3460
Joined: Tue 19 Nov 2002 15:49

Re: Kurven und Vektorpunkte - Bearbeitung hat spürbare Verzögerung (auch Gradation)

Post by Martin Huber » Thu 18 Apr 2019 10:07

Mir ist noch nicht ganz klar, was du machst, wenn das Problem auftritt.
Ashcraaft wrote:
Wed 17 Apr 2019 10:58
Ich habe das Gefühl, dass der "Aktivitätsfokus" des Werkzeugs immer ein paar Millisekunden zu lang auf dem Werkzeug oder dem ausgewählten Pfadpunkt verbleibt. Dies passiert typischerweise, wenn ich während der Pfadbearbeitung auf die Verschiebehand wechsele, um den Bildausschnitt zu verschieben.
Dadurch kommt es häufig vor, dass ich ungewollt den noch aktiven Punkt verschiebe, anstatt den Bildausschnitt.
Du aktivierst die Verschiebehand durch die Leertaste?
Ashcraaft wrote:
Wed 17 Apr 2019 10:58
Das selbe stelle ich ebenfalls beim Modifizieren von Gradationskurven fest.
Oftmals "verreiße" ich so eine Kurve auf ungewollte Extremwerte, weil der Anfasser irgendwie noch "festhängt".
Verwendest du die Gradation als Funktion oder als Arbeitsebene? Wenn es eine Arbeitsebene ist: Bearbeitest du diese im modalen Dialog oder mittels "Ansicht > Dialoge > Arbeitsebene"?

Grundsätzlich ist es so, dass es durch automatisches Speichern und gekapselte Gruppen bzw. Bildern mit Arbeitsebene als Kindern (beim Aufbau des Ausgabecaches) zu kurzen Verzögerungen kommen kann.
Genaueres kann ich aber nur sagen, wenn ich das Problem nachvollziehen kann. Dazu wäre auch ein Beispieldokument hilfreich, mit dem das Problem auftritt.

Martin

Ashcraaft
Mitglied
Posts: 474
Joined: Fri 26 Nov 2010 10:39
Location: Kempen

Re: Kurven und Vektorpunkte - Bearbeitung hat spürbare Verzögerung (auch Gradation)

Post by Ashcraaft » Thu 18 Apr 2019 11:33

Martin Huber wrote:
Thu 18 Apr 2019 10:07
Mir ist noch nicht ganz klar, was du machst, wenn das Problem auftritt.
Du aktivierst die Verschiebehand durch die Leertaste?
Exakt
Martin Huber wrote:
Thu 18 Apr 2019 10:07
Verwendest du die Gradation als Funktion oder als Arbeitsebene? Wenn es eine Arbeitsebene ist: Bearbeitest du diese im modalen Dialog oder mittels "Ansicht > Dialoge > Arbeitsebene"?
Meist als Arbeitsebene und modular.
Martin Huber wrote:
Thu 18 Apr 2019 10:07
Grundsätzlich ist es so, dass es durch automatisches Speichern und gekapselte Gruppen bzw. Bildern mit Arbeitsebene als Kindern (beim Aufbau des Ausgabecaches) zu kurzen Verzögerungen kommen kann.
Genaueres kann ich aber nur sagen, wenn ich das Problem nachvollziehen kann. Dazu wäre auch ein Beispieldokument hilfreich, mit dem das Problem auftritt.
Es handelt sich um einen regelmässigen Versatz im Bereich weniger Millisekunden. Dies ist aber während des flüssigen Arbeitens durchaus negativ spürbar.

Ich schau mal, was ich mit einem Beispieldokument machen kann.
Dieses käme dann per Mail.
Bitte besuche & teile PhotoLine auf folgenden Seiten:
PhotoLine bei Facebook | YouTube

Danke, Sascha Ballweg
(Photoline-Nutzung: Mac OS-X & Windows 7)