Rotate a document

Here everybody can post his problems with PhotoLine
Guest

Rotate a document

Post by Guest » Fri 09 Apr 2004 04:12

Using rotate layer/document (90°), the background canvas dosen't rotate.

Markus
Mitglied
Posts: 16
Joined: Tue 24 Jun 2003 19:36

Post by Markus » Sat 10 Apr 2004 17:56

Works fine here (PL 10.50, Windows). Make sure that "document" AND "picture" are ticked in the dialog.

Guest

Post by Guest » Sun 18 Apr 2004 16:24

Markus wrote:Works fine here (PL 10.50, Windows). Make sure that "document" AND "picture" are ticked in the dialog.
Still counter problem. The canvas doesn't change. A potion of canvas is transparent and many images are hidden.

Guest

Re: Rotate a document

Post by Guest » Mon 19 Apr 2004 05:04

My advice:
PL32 should add a command of Rotate Document

Michael Roek-Ramirez
Betatester
Posts: 484
Joined: Tue 19 Nov 2002 16:16
Location: Darmstadt/Puebla/Shanghai

Works fine

Post by Michael Roek-Ramirez » Mon 19 Apr 2004 15:36

Hello "Guest".
The "rotate document" function works well!
The only thing it does not rotate are the rulers, but here all works as it should do!
You must not use the dialog "layer"-"rotate" but "document"-"rotate"

Regards

Michael

(if you cant figure out, send
1. exact sequence of functions/options you select
2. the document - by mail)

User avatar
Martin Stricker
Mitglied
Posts: 850
Joined: Tue 14 Oct 2003 08:19
Location: BW

Post by Martin Stricker » Mon 19 Apr 2004 16:08

If you want to rotate a document in full 90° steps, including all layers and even the guides, you have to hold down the shift-key and select Layer/Actions/Rotate 90°, 180° or 270°

Martin

Guest

Re: Works fine

Post by Guest » Tue 20 Apr 2004 08:18

Michael Rök-Ramirez wrote:Hello "Guest".
The "rotate document" function works well!
The only thing it does not rotate are the rulers, but here all works as it should do!
You must not use the dialog "layer"-"rotate" but "document"-"rotate"

Regards

Michael

(if you cant figure out, send
1. exact sequence of functions/options you select
2. the document - by mail)
I want to change my picture from "landscape" to "portrait". In menu "document" there is no "rotate xx" (version 10.50). I use menu "layer"-"rotate layer". Options: "90.00", choose"document" and "picture".
All layers are rotated, but the background keeps "landscape". So a potion of the canvas are transparent and a layers are partly hidden.

Thanks for help.

User avatar
Martin Stricker
Mitglied
Posts: 850
Joined: Tue 14 Oct 2003 08:19
Location: BW

Re: Works fine

Post by Martin Stricker » Tue 20 Apr 2004 09:52

Anonymous wrote: I want to change my picture from "landscape" to "portrait". In menu "document" there is no "rotate xx" (version 10.50). I use menu "layer"-"rotate layer". Options: "90.00", choose"document" and "picture".
All layers are rotated, but the background keeps "landscape". So a potion of the canvas are transparent and a layers are partly hidden.

Thanks for help.
What happens if you press the shift-key and choose menu "Layer" - "Actions" - "Rotate 90°" instead. Important the shift-key must be pressed the whole time!

Martin

User avatar
Martin Stricker
Mitglied
Posts: 850
Joined: Tue 14 Oct 2003 08:19
Location: BW

Post by Martin Stricker » Tue 20 Apr 2004 10:07

Now I see the problem. The above mentioned technic only works in document -mode not in picture-mode. I´m sorry I couldn´t help, maybe it is a bug.

Martin

Martin Huber
Entwickler
Entwickler
Posts: 3472
Joined: Tue 19 Nov 2002 15:49

Post by Martin Huber » Tue 20 Apr 2004 16:46

Martin Stricker wrote:Now I see the problem. The above mentioned technic only works in document -mode not in picture-mode. I´m sorry I couldn´t help, maybe it is a bug.
Yes, it seems to be a bug. As a workaround you can do the following:
- Group all layers following the background layer. The background layer must not be part of the group.
- Rotate the background layer. Don't turn "Document" on.
- Rotate the group. Don't turn "Document" on.
- Move the group to the right position and ungroup it.

Sorry for the inconvenience.

Martin