PL debug log? Perfect Effect plugins?

Here everybody can post his problems with PhotoLine
huynhthi870
Mitglied
Posts: 1
Joined: Thu 03 May 2018 11:22

PL debug log? Perfect Effect plugins?

Post by huynhthi870 » Sat 05 May 2018 05:24

Hi folks,

Perfect Effects is giving their plugins away for free, so, of course, I tried them in PL. They do not seem to register. Can I ask for a simple feature request, if it doesn't already exist? Can I have a debug log file of what PL does when it starts up? That way, I can see that it is considering a plugin, and discarding it, instead of silently moving on with no indication that it didn't do anything. If there is a command line parameter, or something I can put into a PL config file to get this log file, it would help when debugging new extensions...

User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3519
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: PL debug log? Perfect Effect plugins?

Post by Gerhard Huber » Sat 05 May 2018 06:14

no, there is no way for you to see what happens.
If the plugin is not listed in PhotoLine, I think it is not 64 bit, like your PhotoLine.
PhotoLine doesn't check anything of the plugin to get it listed, it just has to be "complete" and the right bit depth.

User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3519
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: PL debug log? Perfect Effect plugins?

Post by Gerhard Huber » Sat 05 May 2018 06:25

I downloaded the plugin - 416 MB - OK.
The plugin is not a 8bf plugin, this type of plugins is not supported by PhotoLine.

chrischa
Mitglied
Posts: 97
Joined: Thu 19 Jul 2012 12:02

Re: PL debug log? Perfect Effect plugins?

Post by chrischa » Sat 05 May 2018 18:57

I'm using Perfect Effects as External Program, this works fine.
Photoline 20 unter Windows 10/64 Bit