Neue Testversion 21.90b9

Hier diskutieren die Betatester von PhotoLine untereinander und mit den Entwicklern
User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3799
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: Neue Testversion 21.90b9

Post by Gerhard Huber » Wed 04 Dec 2019 12:34

Herbert123 wrote:
Sun 01 Dec 2019 06:02
Small bug or workflow issue related to multiple selected vector objects and assigning multiple strokes/fills:
1) create two or three vector objects
2) select all the vector objects
3) double-click the fill/stroke entry in the panel properties to add a second set of fill/stroke settings.
Result: only the active object is affected.
Expected/requested result: all selected objects should be assigned the new set of fill/stroke properties.
That's not so easy as you may think. There are many configurations that may crash.
I will try to implement this, but you have to test :D

Martin Huber
Entwickler
Entwickler
Posts: 3652
Joined: Tue 19 Nov 2002 15:49

Re: Neue Testversion 21.90b9

Post by Martin Huber » Wed 04 Dec 2019 13:01

Herbert123 wrote:
Fri 29 Nov 2019 23:37
In the latest betas I noticed strange lasso/selection box behaviour when the bitmap layer is scaled.

I have attached a PLD file. Select the top layer in the layer panel, and drag a new rectangular lasso to capture part of it. Then use the mouse to move this selection.

Result: the movement goes crazy. It also affect the selection handles. It becomes uncontrollable, or only moves in large increments.
I will fix that.

Martin

Martin Huber
Entwickler
Entwickler
Posts: 3652
Joined: Tue 19 Nov 2002 15:49

Re: Neue Testversion 21.90b9

Post by Martin Huber » Wed 04 Dec 2019 13:11

Paul wrote:
Mon 02 Dec 2019 13:47
I have a repeatable crash:
- new document
- create a placeholder layer
- distort with vector path
-> crash
Yes, that's reproducable. I will fix that.

Martin

beiti
Mitglied
Posts: 238
Joined: Sun 16 Nov 2008 01:48

Re: Neue Testversion 21.90b9

Post by beiti » Wed 04 Dec 2019 16:36

Ich teste gerade verschiedene Programme darauf, ob sie unter Windows 10 (1903) das HEIC-Format öffnen können.
Es funktioniert tadellos z. B. mit der Fotos-App von Windows 10 oder auch mit Affinity Photo.
Mit PhotoLine 21.90b9 (gilt möglicherweise auch für frühere Versionen) kommt es beim Versuch, eine HEIC-Datei zu öffnen, entweder zum Komplett-Crash (also PhotoLine wird geschlossen) oder es kommt die Fehlermeldung "Externes Modul für WIC-Import bei der Initialisierung abgestürzt.".

Beispieldateien im HEIC-Format habe ich übrigens aus zwei Quellen:
Hier findet man welche unter "Single image".
Hier muss man immer auf "Download original HEIC" unter den Bildern klicken.

User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3799
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: Neue Testversion 21.90b9

Post by Gerhard Huber » Wed 04 Dec 2019 16:45

beiti wrote:
Wed 04 Dec 2019 16:36
Es funktioniert tadellos z. B. mit der Fotos-App von Windows 10...
wenn das klappt, hast du einen WIC-Treiber installiert. Das zeigt auch die Fehlermeldung von PhotoLine.
Abstürzen sollte PhotoLine natürlich nicht.
Um das nachvollziehen zu können, müsste ich aber wissen, welchen Treiber du verwendest?

User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3799
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: Neue Testversion 21.90b9

Post by Gerhard Huber » Wed 04 Dec 2019 17:01

ich habe jetzt mal den copytransheic-Treiber installiert und die beiden ersten Bilder aus deiner Liste geladen - kein Problem.

beiti
Mitglied
Posts: 238
Joined: Sun 16 Nov 2008 01:48

Re: Neue Testversion 21.90b9

Post by beiti » Wed 04 Dec 2019 17:51

Gerhard Huber wrote:
Wed 04 Dec 2019 16:45
wenn das klappt, hast du einen WIC-Treiber installiert.
Ich habe von mir aus gar nichts installiert. Aber Windows 10 bringt wohl (seit nicht allzu langer Zeit) entsprechende Komponenten selber mit. Ob das dann technisch gesehen ein WIC-Treiber ist, kann ich nicht sagen.

Was ich bisher rausgefunden habe:
Es gibt zwei einschlägige Erweiterungen, die im Microsoft Store angeboten werden. Die eine (kostenlose) Erweiterung ist eine Unterstützung für das HEIF/HEIC-Format generell. Die zweite Komponente (die im Store offiziell für 99 Ct. angeboten wird) ist ein HEVC-Decoder.
Komischerweise sind auf meinem System beide bereits installiert (kann man unter 'Microsoft Store|Downloads und Updates|Alle in meinem Besitz' nachschauen), obwohl ich mich nicht erinnern kann, sie selber installiert zu haben. (Es ist ein selbstinstalliertes Win10 Pro, das ich einst als kostenloses Upgrade von Win7 bekommen habe. Da hat also auch niemand außer mir rumgepfuscht.)
Im Microsoft Store war ich übrigens noch nie angemeldet und habe auch keinen Account, d. h. ich kann die HEVC-Erweiterung gar nicht gekauft haben. Daher vermute ich, dass sie in bestimmten Systemen jetzt kostenlos und automatisch installiert wird.
You do not have the required permissions to view the files attached to this post.

User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3799
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: Neue Testversion 21.90b9

Post by Gerhard Huber » Wed 04 Dec 2019 18:39

Ich habe da jetzt auch mal etwas rumgesucht. Es gibt den 99ct Treiber auch kostenlos im Netz.
Wenn man den installiert, kann ich dein Problem nachvollziehen.
Es liegt daran, dass hier ein "komisches" Format zum übertragen der Bilddaten verwendet wird.
Ich werde das in der nächsten Beta korrigieren.

beiti
Mitglied
Posts: 238
Joined: Sun 16 Nov 2008 01:48

Re: Neue Testversion 21.90b9

Post by beiti » Wed 04 Dec 2019 23:24

Gerhard Huber wrote:
Wed 04 Dec 2019 18:39
Es gibt den 99ct Treiber auch kostenlos im Netz.
Das ist wirklich kurios. Mit der Suche im Store findet man nur "HEVC-Videoerweiterungen" für 99 Ct. Die offenbar baugleiche App "HEVC-Videoerweiterungen vom Gerätehersteller" ist kostenlos, aber im Store nur über Umwege zu finden (Direktlink).
Zusätzlich braucht man in jedem Fall "HEIF-Bilderweiterungen" (Direktlink).

User avatar
OldRadioGuy
Mitglied
Posts: 388
Joined: Fri 24 Apr 2009 19:09
Location: Austin, Texas, USA

Re: Neue Testversion 21.90b9

Post by OldRadioGuy » Thu 19 Dec 2019 01:14

Many of the actions included in this beta are labeled in German, not English. This is also true in the current 21.50 version.
PhotoLine 22.xx | DxO PhotoLab 3 | ON1 Photo RAW 2020 | Affinity Photo 1.8.3 | Various Third-Party Plugins | macOS 10.15 | iMac (Retina 5K, 27-inch, 2017) | Intel Core i7 @ 4.2 GHZ | 32 GB 2400 MHz DDR4 | Radeon Pro 580 8192 MB | E-M1markII, PEN-F.

Paul
Mitglied
Posts: 213
Joined: Fri 19 Dec 2008 11:36

Re: Neue Testversion 21.90b9

Post by Paul » Fri 20 Dec 2019 17:36

Hi,
When I use Placeholderframes and tick 'embed', I would expect that an image that I drag on the Placeholderframe is embedded in the document, so no longer connected to the original image.
I have made such a document and moved it to another computer, but all the photos were gone in the document (of course left on the other computer). The document was still the same size, so I expect that somehow the photo's were indeed embedded in the document, but not shown. But I can't get hold of them.
Or am I missing something?
- Paul

User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3799
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: Neue Testversion 21.90b9

Post by Gerhard Huber » Fri 20 Dec 2019 17:47

OldRadioGuy wrote:
Thu 19 Dec 2019 01:14
Many of the actions included in this beta are labeled in German, not English. This is also true in the current 21.50 version.
I had a look on the default actions of version 21.50. They are all translated here.
I checked the latest beta and it has the same actions.
Perhaps you got some self made actions?
You do not have the required permissions to view the files attached to this post.

User avatar
OldRadioGuy
Mitglied
Posts: 388
Joined: Fri 24 Apr 2009 19:09
Location: Austin, Texas, USA

Re: Neue Testversion 21.90b9

Post by OldRadioGuy » Fri 20 Dec 2019 19:02

No, this the default. See the default screen cap.

Bob
PL_Actions.jpg
You do not have the required permissions to view the files attached to this post.
PhotoLine 22.xx | DxO PhotoLab 3 | ON1 Photo RAW 2020 | Affinity Photo 1.8.3 | Various Third-Party Plugins | macOS 10.15 | iMac (Retina 5K, 27-inch, 2017) | Intel Core i7 @ 4.2 GHZ | 32 GB 2400 MHz DDR4 | Radeon Pro 580 8192 MB | E-M1markII, PEN-F.

Paul
Mitglied
Posts: 213
Joined: Fri 19 Dec 2008 11:36

Re: Neue Testversion 21.90b9

Post by Paul » Sat 21 Dec 2019 10:01

Paul wrote:
Fri 20 Dec 2019 17:36
When I use Placeholderframes and tick 'embed', I would expect that an image that I drag on the Placeholderframe is embedded in the document, so no longer connected to the original image.
I have made such a document and moved it to another computer, but all the photos were gone in the document (of course left on the other computer). The document was still the same size, so I expect that somehow the photo's were indeed embedded in the document, but not shown. But I can't get hold of them.
In short: I see no difference between 'Embed' turned on or off in the Tool settings of the Placement when I drag an image onto the placement frame. It does work when I import an image with the 'Show the file panel' turned on. But usually I first want to position the placeholder frames and then put the images there. This way I make templates for photobooks and calendars.
- Paul

User avatar
shijan
Mitglied
Posts: 352
Joined: Mon 23 Dec 2019 15:21

Re: Neue Testversion 21.90b9

Post by shijan » Mon 30 Dec 2019 00:35

21.90b9 (mac version) crashes when i select custom folder in Preferences->Extended->Plug-in Modules.
No problem in 21.5.
PhotoLine UI Icons Customization Project: https://www.pl32.com/forum3/viewtopic.php?f=3&t=6302