Geheimnisvoller Streifen am Bildrand

Hier diskutieren die Anwender von PhotoLine untereinander
Hening
Mitglied
Posts: 617
Joined: Fri 05 Mar 2010 00:24

Geheimnisvoller Streifen am Bildrand

Post by Hening » Mon 20 Aug 2018 19:50

Hallo zusammen!

Bei einem Bild sehe ich rechts einen schmalen weißen begrenzenden Streifen über die ganze Bildhöhe, vielleicht 1-2 Pixel. Bei einem Laden des Bildes wanderte er von recht nach links, wenn 'Ebenenanfasser anzeigen' eingeschaltet wurde. Nach Schließen und Wieder-Öffnen war der Streifen konstant rechts. -Oh, jetzt entdecke ich den Streifen auch am unteren Bildrand, da ist er noch schmaler, also muss der rechts mindestens 2 Pixel sein.

'Ebenenrahmen anzeigen' ist nicht gewählt. Die Sichtbarkeit von 'Ebenenanfasser' macht keinen Unterschied. Auch nicht, ob ich die Sichtbarkeit einiger oder aller Ebenen ausschalte. Wenn ich 'Extreme Werte markieren' wähle, wird der Streifen rot - dadurch habe ich ihn entdeckt. (Rot=Lichter)

Der Streifen wird nämlich nur sichtbar, wenn ich aus einer etwas kleineren Darstellung heraus eine bestimmte Prozentgröße für das Bild wähle (unten links) und dann Enter drücke. Ich benutze dies, um die Extremwerte im Bild zu markieren, ohne den roten Rand zu sehen. Sonst ist der Rand bei mir weiß, und da wird der Streifen natürlich verschluckt.

Der Fehler scheint sich auf dieses spezielle Bild zu beschränken - ein paar schnelle Stichproben mit anderen Bildern, auch von der selben Camera (Sony a7r1), waren normal.
Neustart des Mac (10.11.6) hilft nicht. - PhotoLine 21.

Was ist dieser weiße Streifen? Wie kann ich ihn los werden? Wird er im Druck erscheinen? Ich fürchte, denn auch das abgeflachte TIF enthält ihn. --edit: auch wenn ich es in Preview öffne. (Ich drucke nicht selbst).

Hening
Mitglied
Posts: 617
Joined: Fri 05 Mar 2010 00:24

Re: Geheimnisvoller Streifen am Bildrand

Post by Hening » Mon 20 Aug 2018 20:12

Ups ich glaube ich hab die Ursache. Das Bild ist ein Belichtungs-Triplet, das in Lumariver HDR gestackt ist. Hierbei scheint der Streifen entstanden zu sein. Ich werd jetzt also versuchen, unten 1 und rechts 2 Pixel vom Bild abzuschneiden. Sorry, hatte also nichts mit PL zu tun.

Hening
Mitglied
Posts: 617
Joined: Fri 05 Mar 2010 00:24

Re: Geheimnisvoller Streifen am Bildrand

Post by Hening » Mon 20 Aug 2018 20:31

Hm... Oder doch?
Die Rohbilder sind alle 4.912x7.360 px. Nach Konvertierung mit RawTherapee sind davon noch 4.912x7.354 übrig - und diese Pixelzahl hat auch der Stack, und der Hintergrund des Bildes in PL und alle Ebenen. So woher kommen die Streifen?

Martin Huber
Entwickler
Entwickler
Posts: 3671
Joined: Tue 19 Nov 2002 15:49

Re: Geheimnisvoller Streifen am Bildrand

Post by Martin Huber » Tue 21 Aug 2018 07:57

Ohne ein Beispielbild kann ich da schlecht was sagen. Hast du einen Link?

Martin

Hening
Mitglied
Posts: 617
Joined: Fri 05 Mar 2010 00:24

Re: Geheimnisvoller Streifen am Bildrand

Post by Hening » Tue 21 Aug 2018 14:11

Hallo Martin!
Danke für deine schnelle Antwort. Link ist hier: https://www.dropbox.com/s/yx9khi3ch6saw ... f.pld?dl=0
(180 MB!)

Hening
Mitglied
Posts: 617
Joined: Fri 05 Mar 2010 00:24

Re: Geheimnisvoller Streifen am Bildrand

Post by Hening » Tue 21 Aug 2018 20:43

Jetzt habe ich noch ein Bild entdeckt mit solchen Rändern. Und mehr. Das Original hatte einen solchen Rand von 1 px an der rechten Seite. Hab ich entfernt mit 'Dokumentgröße ändern'. Dann öffne ich den Softproof (der als Dup des Originals entstanden ist) - der hat einen solchen Streifen unten, ca 2 px. Nee jetzt beim erneuten Öffnen nicht mehr! ???

Im Übrigen habe diese beiden Bilder eins gemeinsam: Ich habe sie beschnitten. Dabei verwende ich immer den Trick mit Alt-Taste, um die Seite(n), die ich NICHT beschneiden will, pixelgenau zu erhalten. Kann das einen Hinweis geben?

Martin Huber
Entwickler
Entwickler
Posts: 3671
Joined: Tue 19 Nov 2002 15:49

Re: Geheimnisvoller Streifen am Bildrand

Post by Martin Huber » Tue 21 Aug 2018 21:19

Ich habe dein Bild mal geladen:
- Die aktive Ebene ist die Hintergrundebene.
- In den Einstellungen ist unter "Anzeige > Dokument" die Randfarbe auf schwarz gestellt.
- Der Zoom ist 400%.

Dann sieht der rechte Rand des Bildes so aus:
Screenshot.png
Man sieht also eine graue Linie, die 1 Pixel breit ist. Wie gesagt, bei einem Zoom von 400%, ein Bildpixel ist also 4x4 Bildschirmpixel groß.
Diese graue Linie ist also kein Teil des Dokuments, sondern eine Markierung von PhotoLine und zwar der Rahmen, der um die aktive Seite gezeichnet wird.

Dann habe ich das Dokument - wie von dir beschrieben - als TIFF exportiert und in der Apple Vorschau geöffnet. Dort war die graue Linie nicht vorhanden.

Ich kann das Problem also nicht nachvollziehen.
Sieht bei dir die Linie anders aus?

Martin
You do not have the required permissions to view the files attached to this post.

Hening
Mitglied
Posts: 617
Joined: Fri 05 Mar 2010 00:24

Re: Geheimnisvoller Streifen am Bildrand

Post by Hening » Tue 21 Aug 2018 22:29

Danke für deine schnelle Antwort. Ich werde das morgen nochmal alles checken. Schon jetzt fällt mir aber ein:
Bei mir war der Streifen rechts (und unten), aber nicht links. Und nachdem ich rechts und unten 2 bzw 1 Pixel vom Bild abgeschnitten habe, sind die Streifen weg. - Die Markierungen, die du beschreibst - sind das (nicht) die Ebenenrahmen?

User avatar
der_fotograf
Mitglied
Posts: 362
Joined: Mon 05 Dec 2016 08:33

Re: Geheimnisvoller Streifen am Bildrand

Post by der_fotograf » Wed 22 Aug 2018 08:09

Ich sehe die Streifen nicht.

Achtung bei RawTherapee: Es konvertiert die Netto-Fläche des Sensors und liegt damit ausserhalb der Spezifikationen, d.h. es werden Randpixel konvertiert, die der Hersteller nicht als Endformat definiert hat. Konvertiere mal mit dem Konverter, der mit der Kamera kommt, dann siehst Du, wie viel mehr RT konvertiert. Genau dieses Differenz solltest Du vom TIFF abschneiden.

Weitere Möglichkeit: Retina-Display? Ich habe kein Retina...

Eine Ebene (Gradation Image) ist einen Tick kleiner als der Hintergrund. Könnte auch eine Ursache sein.

Was ich aber sehe: Deine Belichtung stimmt nicht. Nimm mal einen Sekonic und kalibriere Deine Kamera damit. RT konvertiert normalerweise sehr weich. Siehst Du, wenn Du alle oberen Ebenen ausblendest, dann ist nur im hellen Baum eine Stelle ausgefressen (-> Kalibrierung!) Oder ist das ein Fehler im Prozess, der auf ETTR begründet ist? ETTR ist der grösste Unsinn, der im iNet kolportiert wird. Hatte ich aber glaube ich schon mal geschrieben. 'Oben' immer Luft lassen, die Schatten dann etwas anheben - spart Dir viele Ebenen und Arbeit. Die Stärke von RT ist, die Schatten trotzdem gut zu entwickeln, ohne dass Du Dir damit ein Rauschen einfängst. Nur kann RT keine CA beseitigen.

Ausserdem sind in einer Ebene Artefakte oder Retusche-Teile drin, die den hellen Baum verändern. Wozu die gut sein sollen, erschliesst sich mir nicht.

Aus welchem Grund Du 'pixelgenau' beschneidest, weiss ich nicht. Kein Drucker druckt pixelgenau, nicht mal ein Lambda oder LightJet.

Bei mir sind die Einstellungen unter Display -> Document: Edge width: 50%, Color: White. (Ich weiss nicht einmal, wofür das gut sein soll, da ich grundsätzlich im Picture Mode arbeite, aber Du ja auch, wie ich eben nachgesehen habe)

Ich habe mal alle Ebenen ausgeschaltet und eine einfache Kurve draufgelegt. Keine Artefakte, keine geheimnisvollen Streifen, nichts:
Screen Shot 2018-08-22 at 08.07.32.png
Wenn Du es noch knackiger willst, kannst Du den Kontrast noch weiter anheben, aber dann saufen die Schattenpartien gnadenlos ab - digitale Fotos haben im Gegensatz zu Negativfilm keine Reserven.
You do not have the required permissions to view the files attached to this post.
--------------------------------------------
Nur wenige wissen, wie viel man wissen muss, um zu wissen, wie wenig man weiss.
— Werner Heisenberg

Martin Huber
Entwickler
Entwickler
Posts: 3671
Joined: Tue 19 Nov 2002 15:49

Re: Geheimnisvoller Streifen am Bildrand

Post by Martin Huber » Wed 22 Aug 2018 08:45

Hening wrote:
Tue 21 Aug 2018 22:29
Danke für deine schnelle Antwort. Ich werde das morgen nochmal alles checken. Schon jetzt fällt mir aber ein:
Bei mir war der Streifen rechts (und unten), aber nicht links. Und nachdem ich rechts und unten 2 bzw 1 Pixel vom Bild abgeschnitten habe, sind die Streifen weg.
Bei mir sind die grauen Linien auf allen Seiten, aber abhängig von der Randfarbe (in den Einstellungen unter "Anzeige > Dokument") und dem Bildinhalt sind sie nur an manchen Stellen bemerkbar.
Hening wrote:
Tue 21 Aug 2018 22:29
- Die Markierungen, die du beschreibst - sind das (nicht) die Ebenenrahmen?
Nein. Das, was auf meinem Screenshot zu sehen ist, ist der Rahmen um das gesamte Dokument. Der ist auch nicht abschaltbar.

Martin

User avatar
der_fotograf
Mitglied
Posts: 362
Joined: Mon 05 Dec 2016 08:33

Re: Geheimnisvoller Streifen am Bildrand

Post by der_fotograf » Wed 22 Aug 2018 21:27

Martin Huber wrote:
Wed 22 Aug 2018 08:45
Nein. Das, was auf meinem Screenshot zu sehen ist, ist der Rahmen um das gesamte Dokument. Der ist auch nicht abschaltbar.

Martin
Ähm, ganz blöde Frage: Ich sehe da bei mir keinen Rahmen. Kann das daran liegen, dass ich kein Retina-Display habe? Ich habe die Datei einfach nur runtergeladen und mit PL geöffnet, also keine Einstellungen verändert.

Wenn es nicht daran liegt - warum sehe ich den schwarzen Rand nicht? Oder einen weissen? Woher kommen die Differenzen in der Darstellung?
--------------------------------------------
Nur wenige wissen, wie viel man wissen muss, um zu wissen, wie wenig man weiss.
— Werner Heisenberg

Hening
Mitglied
Posts: 617
Joined: Fri 05 Mar 2010 00:24

Re: Geheimnisvoller Streifen am Bildrand

Post by Hening » Wed 22 Aug 2018 22:13

Danke für deine "Einmischung", _fotograf.
Ich antworte zunächst mal auf deinen post vor Martins, aber zunächst nur auf die Teile welche die Streifen betreffen. ("Klage gegen Sie behalten wir uns vor" ;-) )

>Achtung bei RawTherapee: Es konvertiert die Netto-Fläche des Sensors und liegt damit ausserhalb der Spezifikationen, d.h. es werden Randpixel konvertiert, die der Hersteller nicht als Endformat definiert hat. Konvertiere mal mit dem Konverter, der mit der Kamera kommt, dann siehst Du, wie viel mehr RT konvertiert.

Dass ein Konverter mit der Camera kommt, war mir nicht bewusst. Jedenfalls hab ich ihn nicht installiert. In meinem Fall scheint es eher so zu sein dass RT rechts und links je 3 px abschneidet. Ein TIF aus Iridient hat jedenfalls auch 4912x7360 px, wie das Rohbild.

> Ich sehe die Streifen nicht.

Wenn ich das Bild einfach per Doppelklick öffne, sehe ich auch keinen. Er erscheint erst, wenn ich wie beschrieben unten links <23>% eingebe und dann Enter drücke. Und nur rechts.

> Retina-Display?

Ich hab zwar ein MacBook mit Retina Schirm, aber für die Bildbearbeitung benutze ich einen Eizo mit 96 ppi.


>Eine Ebene (Gradation Image) ist einen Tick kleiner als der Hintergrund. Könnte auch eine Ursache sein.

Bei mir sind alle Ebenen 4912x7354 px laut Anzeige von 'Ebene skalieren'.

Das Folgende gilt jetzt vielleicht auch für Martin:

Uff uff - nach etwas Rumklicken ist jetzt der Streifen rechts zwar da, aber er ist nicht rot, obwohl 'Extreme Werte markieren' eingeschaltet ist. ???

Und wenn ich das Bild maximiere mit alt-cmd-minus ist kein Streifen da. ???

Könnte das darauf deuten, dass der ganze Spuk nur ein inkonstanter Fehler ist, vielleicht bedingt dadurch, dass die Bildschirmauflösung nur 96 ppi ist, die eingestellte Auflösung der Bilddatei aber 360 ppi?

Und jetzt zum _fotografen Teil 2:

> Deine Belichtung stimmt nicht
Das Bild ist wie gesagt ein Stack aus 3 Belichtungen. Aus dem Ergebnis kannst du vermutlich kaum Rückschlüsse auf die (nicht vorhandene) Kalibrierung der Camera ziehen. Einen Sekonic habe ich auch nicht und vermisse ich auch nicht. Was ich vermisse wäre ein live-Histogramm der Camera, das sich auf das Rohbild bezieht. Guillermo Luijk hat kürzlich auf Luminous Landscape Unterschriften gesammelt für eine diesbezügliche Petition an die Camera-hersteller. Schaun wer mal...

> Nur kann RT keine CA beseitigen.

??? RT's (automatische) Korrektur von (lateraler) CA ist der Grund dafür, dass ich von Iridient zu RT gewechselt bin für die Rohkonvertierung. Schon vorher hatte ich RT's manuelle Korrektur der longitudinalen CA benutzt.

> Ausserdem sind in einer Ebene Artefakte oder Retusche-Teile drin, die den hellen Baum verändern. Wozu die gut sein sollen, erschliesst sich mir nicht.

Du meinst vermutlich die Ebenenmaske in der Ebenengruppe 'EM Erle'. Und du hast Recht: Sie ist zu nichts gut - im Gegenteil! Danke für den Hinweis!

Es ist eine Automaske, die dazu gedacht war, (mit Hilfe der Grad Kurve), die Spitzlichter auf dem Stamm zu dämpfen. Das tut sie auch. Aber die Gruppe als Ganzes geht nach hinten los--??

Übrigens, es waren einige Ebenen dieser Gruppe, die in der Ebenenliste unten (und links) einen Streifen Transparenz zeigten, wie ich jetzt sehe. Das ist wohl das was du als etwas kleinere Ebene gesehen hast. Jetzt nach etwas Verschieben der Ebenen, Löschen und Undo und Rumklicken ist die Transparenz verschwunden...??

> Aus welchem Grund Du 'pixelgenau' beschneidest, weiss ich nicht. Kein Drucker druckt pixelgenau, nicht mal ein Lambda oder LightJet.

Ach ich möchte nicht dass mehr abgeschnitten wird als nötig. Besonders wenn man vielleicht den Beschnitt nachbessert könnte sich das anhäufen...

> Ich habe mal alle Ebenen ausgeschaltet und eine einfache Kurve draufgelegt.

Die Bildwiedergabe, die sich ergibt, ist allerdings nicht...eh...nach meinem Geschmack. Aber über solchen ist bekanntlich nicht zu streiten, und das will ich auch nicht. :-)

Gut Licht!

User avatar
der_fotograf
Mitglied
Posts: 362
Joined: Mon 05 Dec 2016 08:33

Re: Geheimnisvoller Streifen am Bildrand

Post by der_fotograf » Thu 23 Aug 2018 06:59

> Ich habe mal alle Ebenen ausgeschaltet und eine einfache Kurve draufgelegt.
Die Bildwiedergabe, die sich ergibt, ist allerdings nicht...eh...nach meinem Geschmack. Aber über solchen ist bekanntlich nicht zu streiten, und das will ich auch nicht. :-)
Nein, ist klar, war auch nicht meine Absicht. Es sollte nur eine Möglichkeit zeigen, die ausgefressenen Lichter zu dämpfen. Weitere Schritte würden folgen...
Ach ich möchte nicht dass mehr abgeschnitten wird als nötig. Besonders wenn man vielleicht den Beschnitt nachbessert könnte sich das anhäufen...
Geschnitten wird am Schluss ;-), d.h. nach dem Druck. Anlage des Fotos 3 mm grösser (bleed), dann ein sauberer Schnitt des Bogens und es passt.

RT und CA - arbeitete in älteren Versionen leider nicht sauber, kann nicht war insofern falsch.

RAW Histogram wäre schön, wird aber nichts werden. Nützt auf den Mäusekinos auf den Rückseiten der Kamera auch nicht viel, weil die kleinen Spitzen der Lichter darauf nicht zu erkennen sind. Wer dann mit der ETTR-Methode arbeitet, hat immer noch ausgefressene Lichter.
Könnte das darauf deuten, dass der ganze Spuk nur ein inkonstanter Fehler ist, vielleicht bedingt dadurch, dass die Bildschirmauflösung nur 96 ppi ist, die eingestellte Auflösung der Bilddatei aber 360 ppi?
Das glaube ich eher weniger, dann müsste ich bei meinen 4.000 ppi Scans gewaltige Probleme haben.
Aus dem Ergebnis kannst du vermutlich kaum Rückschlüsse auf die (nicht vorhandene) Kalibrierung der Camera ziehen.
Nun ja, wenn der Belichtungsmesser/die Kamera kalibriert ist, gibt es keine ausgefressenen Lichter, was die Konvertierung erheblich vereinfacht. Aber das ist ein Thema für ein Buch oder Workshop.
Du meinst vermutlich die Ebenenmaske in der Ebenengruppe 'EM Erle'. Und du hast Recht: Sie ist zu nichts gut - im Gegenteil! Danke für den Hinweis!
Gut, dass wir darüber gesprochen haben ;-)
--------------------------------------------
Nur wenige wissen, wie viel man wissen muss, um zu wissen, wie wenig man weiss.
— Werner Heisenberg

Martin Huber
Entwickler
Entwickler
Posts: 3671
Joined: Tue 19 Nov 2002 15:49

Re: Geheimnisvoller Streifen am Bildrand

Post by Martin Huber » Thu 23 Aug 2018 09:02

der_fotograf wrote:
Wed 22 Aug 2018 21:27
Ähm, ganz blöde Frage: Ich sehe da bei mir keinen Rahmen. Kann das daran liegen, dass ich kein Retina-Display habe? Ich habe die Datei einfach nur runtergeladen und mit PL geöffnet, also keine Einstellungen verändert.

Wenn es nicht daran liegt - warum sehe ich den schwarzen Rand nicht? Oder einen weissen? Woher kommen die Differenzen in der Darstellung?
Ob der Rand schwarz ist oder eine andere Farbe hängt von der Einstellung unter "Anzeige > Dokument" ab. Da kann man getrennt für den Dokument- und den Bildmodus einstellen, wie breit der Rahmen ums Dokument sein soll (relativ zur Dokumentgröße), und eben die Farbe.

Ist die Rahmenbreite 0%, wird kein Rahmen ums Dokument angezeigt, außer das Dokument ist kleiner als das Fenster.

Und wenn bei dir keinen Dokumentrand hast, dann siehst du auch die graue Linie ums Dokument nicht, weil sie mit dem Fenster "verschmilzt". SIe ist zwar da, fällt aber nicht auf.

Martin

Hening
Mitglied
Posts: 617
Joined: Fri 05 Mar 2010 00:24

Re: Geheimnisvoller Streifen am Bildrand

Post by Hening » Thu 23 Aug 2018 19:01

Hallo nochmal
Ich hab jetzt noch mal ein Bisschen rumprobiert und aufgeschrieben.

log
2015.09.30 M4
20% - rot unten (rot = Hochton-clips)
23% - rot rechts
maximiert mit alt-cmd-minus - kein Rot
10% nix
15% nix
20% rot unten
21% rot rechts
20% rot unten (dh auch nach Verkleinerung)
30% rot rechts

abgeflacht zum TIF bei 23%: nach Schließen und Wieder-Öffnen in PL:
15% nix
20% rot unten
23% rot rechts
maximiert mit alt-cmd-minus: nix

TIF in Preview:
Weißer Streifen rechts
verschwindet wenn ich das Bild vergrößere durch Klick auf +.
Bleibt danach weg auch bei Verkleinerung.

Beim Vergrößern in Preview sehe ich kurz ein Zwischenstadium, bei dem rechts noch ein schmaler Rand fehlt, bevor das Bild fertig aufgebaut ist.

Wenn ich den Bildrand begucke mit der in Digital Color Meter eingebauten Vergrößerung, dann sehe ich sowohl den grauen Dokumentrahmen als auch - außen davon - meinen roten Rand. Leider kann ich das nicht im screen shot dokumentieren.
Bei 10 und 15% sehe ich auch mit der Lupe kein Rot.
Wenn ich 'Extreme Werte markieren' ausschalte, sehe ich auch mit der Lupe einen weißen Streifen statt den roten.

Kann das irgendwie weiter führen?

Nachschlag:
Ein flaches TIF, von dem ich rechts 2 und unten 1 px abgeschnitten hatte, zeigt bei Wiedergabe in PL unten den roten Rand - bei 15% - aber nicht bei 10 und 20%.

Nachschlag 2:
Im Originalbild habe ich jetzt die Gruppe 'EM Erle' gelöscht. Danach ist bei 20% der rote Streifen unten nur noch blass-rot. Im Softproof ist die Gruppe noch. Wenn ich ihre Sichtbarkeit in der Ebenengruppe ausschalte, ist der Streifen weiterhin 'lecker' rot.