DeJPEG Plugin Support Desired

Here everybody can post his problems with PhotoLine
User avatar
Koyaanis
Mitglied
Posts: 217
Joined: Mon 25 Sep 2006 20:23

DeJPEG Plugin Support Desired

Post by Koyaanis » Thu 25 Oct 2007 11:46

I've been looking for a decent JPEG artifact removal tool for use in PL32. I miss the one I used to have in PSP, which was okay, but not great. I ran across this freeware one tonight and it does a pretty good job. It would be nice it if had even more options, but I think it's still nicer than the one I liked so much in PSP.

http://pcwin.com/Multimedia___Design/To ... wnload.htm

BUT, it only seems to work in my other graphic editors.

Could PL32 support this plugin?

Or even better, could PL32 have a JPEG artifact remover even better than this one?? :-)

Thanks if you can do either!

User avatar
Hoogo
Betatester
Posts: 3865
Joined: Sun 03 Jul 2005 13:35
Location: Mülheim/Ruhr

Post by Hoogo » Thu 25 Oct 2007 12:01

I have used this one quite a while ago, and I think that has been in Photoline. I will check again later.

User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3841
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Post by Gerhard Huber » Thu 25 Oct 2007 16:21

I downloaded the plugin.
It doesn't work. I debugged it and it crashes inside the plugin. Since there are no debug infos, I can't get further information.
I am sorry (today the second time :-)) but the only way to fix those problems would be help from the plugin developer. In the past I contacted several of those guys. From most of them, I got no answer. Some of them told me, that they don't know what's going on, because they use "Filter Meister". I don't want to contact them anylonger.
Please try to do it from your site.

Gerhard

User avatar
Koyaanis
Mitglied
Posts: 217
Joined: Mon 25 Sep 2006 20:23

Post by Koyaanis » Tue 30 Oct 2007 05:03

I wrote to them after you asked. No reply, not even a form-letter reply. Was worth a shot though.

I have some bandwidth free for a few days (rare on my dial-up connection). I'll hunt around the net for other JPEG cleaners. Unless (ahem), you might include one in the next version.

lutz
Mitglied
Posts: 376
Joined: Wed 12 Apr 2006 19:53

Post by lutz » Tue 30 Oct 2007 20:15

This one is free:

http://www.vicman.net/jpegenhancer/index.htm

it is not a plugin however.

User avatar
Koyaanis
Mitglied
Posts: 217
Joined: Mon 25 Sep 2006 20:23

Post by Koyaanis » Thu 08 Nov 2007 10:58

Okay, cool. That Topaz DeJPEG no longer crashes in PL32 V14.

(this one http://pcwin.com/Multimedia___Design/To ... wnload.htm )

BUT, it doesn't work either. It seems to work fine when you load it, the preview in the plugin works just fine if I work on the background layer or a duplicate later, but then when you hit okay to apply it only returns to PL32 with no change to the image.

If I enable "use transparency" in the background or layer, then the preview in the plugin is all mangled (odd colors, bands, half shown image), BUT when I hit okay then it acts like it's applying it in PL32. The progress guage in the status bar shows it's being applied, just like when using all other plugins and filters. But then again, no change to the actual image.

SO .... It wants to work with PL32, but it don't. :-(

So close, but no cigar. :-)