Version 12.5 crashes on browse?

Here everybody can post his problems with PhotoLine
Happy-Hacker

Version 12.5 crashes on browse?

Post by Happy-Hacker » Sat 15 Apr 2006 00:38

I just downloaded version 12.5 and every time I try to browse, the application crashes. I've erased all the browse.pl files, with the thought that they may be corrupt or too old to function with the new version, but this has not helped. Raising the memory usage limit from 128mb to unlimited lets the application not die immidiately, but it still crashes if you try to resize the browse window.

User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3839
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: Version 12.5 crashes on browse?

Post by Gerhard Huber » Sat 15 Apr 2006 06:14

Happy-Hacker wrote:I just downloaded version 12.5 and every time I try to browse, the application crashes. I've erased all the browse.pl files, with the thought that they may be corrupt or too old to function with the new version, but this has not helped. Raising the memory usage limit from 128mb to unlimited lets the application not die immidiately, but it still crashes if you try to resize the browse window.
"Memory Limitation" sounds like Mac OS 9.
It's a problem to get enough memory on Mac OS 9 for some functions.
Is there a problem if you test the browse function on a small image folder?

Gerhard

Strick
Mitglied
Posts: 4
Joined: Sun 16 Apr 2006 07:12
Location: Colorado, U.S.A.

re: crash on browse

Post by Strick » Sun 16 Apr 2006 07:34

No, this was in the undo history memory usage configuration. I'm running pl32 under OS X 10.4.6 with 2gb of RAM on a dual G5 1.8ghz. I just tried it again with the following results:

Start pl32.
go to the file menu
click on browse.
browse opens to my document directory.
If I click on any control in the browse window after that, PL32 crashes.

And yes, Happy-Hacker was me, but I'm told that my account was deleted due to recent hacking on this board. A change of sobriquet seemed like a good idea.
"So this is how liberty ends: with thunderous applause." - Padme' Amidala-Skywalker

User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3839
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: re: crash on browse

Post by Gerhard Huber » Sun 16 Apr 2006 08:52

Strick wrote:No, this was in the undo history memory usage configuration. I'm running pl32 under OS X 10.4.6 with 2gb of RAM on a dual G5 1.8ghz. I just tried it again with the following results:
Start pl32.
go to the file menu
click on browse.
browse opens to my document directory.
If I click on any control in the browse window after that, PL32 crashes.
Do the preview images appear?
Can you test this on a little test folder? Does it occur here, too?

Gerhard

Strick
Mitglied
Posts: 4
Joined: Sun 16 Apr 2006 07:12
Location: Colorado, U.S.A.

PL32 12.5 browse crash

Post by Strick » Sun 16 Apr 2006 09:01

Yes, I get one preview image. How do I tell Browse to go to a different folder without touching the browse window?
"So this is how liberty ends: with thunderous applause." - Padme' Amidala-Skywalker

User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3839
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: PL32 12.5 browse crash

Post by Gerhard Huber » Sun 16 Apr 2006 10:03

Strick wrote:Yes, I get one preview image. How do I tell Browse to go to a different folder without touching the browse window?
You can drag the "Test Folder" to the PL32 icon on the stock. Then PL32 will open this folder in the browse window.

Gerhard

Strick
Mitglied
Posts: 4
Joined: Sun 16 Apr 2006 07:12
Location: Colorado, U.S.A.

re PL32 browse crash

Post by Strick » Sun 16 Apr 2006 22:23

That works fine. Browse works as advertised both with a small directory and one containing 450 jpg images. It also works fine in a directory full of raw (PEF) images. It sounds like it's gagging on something in my documents directory. Is there any way I can change the default directory browse opens when I click on browse in the file window?
"So this is how liberty ends: with thunderous applause." - Padme' Amidala-Skywalker

User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3839
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: re PL32 browse crash

Post by Gerhard Huber » Mon 17 Apr 2006 06:01

Strick wrote:That works fine. Browse works as advertised both with a small directory and one containing 450 jpg images. It also works fine in a directory full of raw (PEF) images. It sounds like it's gagging on something in my documents directory. Is there any way I can change the default directory browse opens when I click on browse in the file window?
Normally it opens in the directory you used last time.
But now you can try to find out which of the images in you "Standard Folder" is the problem. If you could send it to me, I will fix the problem.

Gerhard

Strick
Mitglied
Posts: 4
Joined: Sun 16 Apr 2006 07:12
Location: Colorado, U.S.A.

problem file

Post by Strick » Mon 17 Apr 2006 06:37

My suspicion is that it was a file called BootX.raw that was making the browse function barf. I deleted it to test it earlier and now I cannot replicate the crash. Unfortunately I do not have a copy of the file.
"So this is how liberty ends: with thunderous applause." - Padme' Amidala-Skywalker