Opening files from Windows Explorer opens image twice.

Here everybody can post his problems with PhotoLine
User avatar
Koyaanis
Mitglied
Posts: 217
Joined: Mon 25 Sep 2006 20:23

Opening files from Windows Explorer opens image twice.

Post by Koyaanis » Tue 24 Oct 2006 23:33

I have an odd situation. When I double-click on an image from Windows Explorer, or use the Right-click "Open With" option, an image will open twice inside of one-instance PL32 (v13.01).

Normally this is caused by an odd string in the registry. I looked under:

HKEY_CLASSES_ROOT\Applications\PhotoLine.exe\shell\open\command

Where I find the string of:

C:\Program Files\PhotoLine32_v13\PhotoLine.exe "%1"

But shouldn't that be?:

"C:\Program Files\PhotoLine32_v13\PhotoLine.exe" /dde

Yet when I change it to that, and try to open an image again in PL32 with "Open With" it still opens the image twice, then when I check that registry setting again it has been rewritten by PL32 to the original string of:

C:\Program Files\PhotoLine32_v13\PhotoLine.exe "%1"

Is this something that went haywire when I tried re-associating file types with other programs and then back to PL32 and then to other programs again? Or is it because I have both v12 and v13 installed and the two installations are getting a cross-linked "Open With" command? This seemed to have cropped up after I installed v13.

Could I fix this just by deleting this registry key?

HKEY_CLASSES_ROOT\Applications\PhotoLine.exe\shell\open\ddeexec\[open("%1")]

so it won't be tempted to open a file through the /dde command too?

Or, come to think of it, I also made a "UserSettings" sub-folder so I could always just drag and drop all my settings to a memory-card as I customize my workspace. Could that be competing with PL32's looking for user-settings elsewhere? I shouldn't play with these options so much, too many variables make it hard to pin down the problem. :)

User avatar
Koyaanis
Mitglied
Posts: 217
Joined: Mon 25 Sep 2006 20:23

Post by Koyaanis » Wed 25 Oct 2006 19:07

Nevermind! I fixed it.

Seems I couldn't edit those registry entries directly. I had to use the Windows Explorer "Folder Options", "File Types".

I had to let WinXP clear the old associations by hitting the reset button on the affected file-types. Then I selected "Advanced". In there, I found the strings to the program as stated above. The paths were not surrounded in quotes, and Windows refused to find the PhotoLine.exe file without the quotes enclosing the path to it. So I had to manually browse to where the exe file was and let Windows re-insert the proper quotes (highlighted here in red) around the path string. I also turned off "Use DDE" on each one.

Here's the strings I have for each file-association entry:

Open with PhotoLine 32: "C:\Program Files\PhotoLine32_v13\PhotoLine.exe" "%1"

Open with PhotoLine Viewer: "C:\Program Files\PhotoLine32_v13\PhotoLine.exe" -view "%L"

Print: "C:\Program Files\PhotoLine32_v13\PhotoLine.exe" /p "%1"

PrintTo: "C:\Program Files\PhotoLine32_v13\PhotoLine.exe" /pt "%1" "%2" "%3" "%4"


Uh oh .... well, it worked ONE time. Now I see that after letting PL32 open an image one time correctly, it re-wrote all those strings in the registry back to having no quotes around the paths. And it turned on "Use DDE" to all of them again. I'm back to PL32 opening an image twice (an extra copy in the editor window).

Can you check to be sure that PhotoLine is putting those quotes around those registry strings? I don't know if this is just something screwed up on my system or if it's built into the newer PL32. It's not behaving properly without those quotes. :? I think something's not right. Shouldn't those strings end in /dde if using DDE, or "%(value)" if not using DDE? At least I think that's how it should work. Yes? No? I'm confused.

User avatar
Koyaanis
Mitglied
Posts: 217
Joined: Mon 25 Sep 2006 20:23

Post by Koyaanis » Wed 25 Oct 2006 19:35

Okay, I temporarily fixed it by:

Entering the above strings manually for each file-type. Turning off "Use DDE" on each one. To prevent PL32 from re-writing them each time when I open PL32 I had to turn off its file-associations. So it won't check them each time it opens. (Under Edit > Options > File > File Format, and unchecking each one that I use often.)

Again, I don't know if this is something I've done wrong (or Windows is doing), but it seems like PL32 isn't writing those file associations properly.