Neue Testversion 20.90b8

Hier diskutieren die Betatester von PhotoLine untereinander und mit den Entwicklern
User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3893
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Neue Testversion 20.90b8

Post by Gerhard Huber »

Hallo,

es gibt wieder eine neue Testversion 20.90b8.

Windows:
http://www.pl32.com/beta/pl2090b8.zip


Mac OS:
http://www.pl32.com/beta/plx2090b8.zip



Neues:
  • Lasso-Werkzeuge: Arbeiten nun mit allen Ebenentypen
  • Farbfilter-Dialog: Umschalt+Klick in Dokumentfenster setzt Hintergrundfarbe
diverse kleine Fehler beseitigt
User avatar
Herbert123
Mitglied
Posts: 1953
Joined: Sat 12 May 2012 21:38

Re: Neue Testversion 20.90b8

Post by Herbert123 »

Gerhard Huber wrote: Tue 06 Mar 2018 16:37 Neues:
  • Lasso-Werkzeuge: Arbeiten nun mit allen Ebenentypen
Wohoo! :D
/*---------------------------------------------*/
System: Win10 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), Nvidia GTX1080 8GB, Revodrive X2 240gb, e-mu 1820, 2XSamsung SA850 (2560*1440) and 1XHP2408H 1920*1200 portrait
User avatar
asharpe
Mitglied
Posts: 90
Joined: Mon 23 Dec 2013 07:01
Location: Palo Alto, California, USA

Re: Neue Testversion 20.90b8

Post by asharpe »

Here's an interesting issue with the b8 beta. I edit an image, and zoom to about 100%, and everything is fine. After that, I zoom a bit more, and the pictures gets odd with a lot of vertical lines. I couldn't attach images that were so large, so I put them on my web site. Here's screen shots that show it:

56% zoom
http://andrewsharpe.com/56%zoom.png

100% zoom
http://andrewsharpe.com/100%zoom.png

119% zoom
http://andrewsharpe.com/119%zoom.png

169% zoom
http://andrewsharpe.com/169%zoom.png
Martin Huber
Entwickler
Entwickler
Posts: 3757
Joined: Tue 19 Nov 2002 15:49

Re: Neue Testversion 20.90b8

Post by Martin Huber »

asharpe wrote: Wed 07 Mar 2018 07:16 Here's an interesting issue with the b8 beta. I edit an image, and zoom to about 100%, and everything is fine. After that, I zoom a bit more, and the pictures gets odd with a lot of vertical lines. I couldn't attach images that were so large, so I put them on my web site. Here's screen shots that show it:
I can't reproduce that here on macOS 10.13. Did you make any changes the to DNG after loading it or is it imported using PhotoLine's default settings.

You have turned on "View > Pixel Mode" and "View > Mark Extreme Values". Does turning off one or both of them change anything?

Does the problem still show up when you scale down the document to a width of - let's say - 128 pixels? If so, you could send us this scaled down document by e-mail. Otherwise you could upload the full version and send us the link, so that we can check if we can reproduce the problem with that file.

Martin
User avatar
Herbert123
Mitglied
Posts: 1953
Joined: Sat 12 May 2012 21:38

Re: Neue Testversion 20.90b8

Post by Herbert123 »

The other day I received a HEIF/HEIC image file. I couldn't open it, and after doing some research it turns out to be a new image container format developed by the MPEG group, and now starting to be used by iOS mobile devices.

I am no fan at all of this development since HEIF is a heavily licensed and proprietary format that I think is just another attempt to gain control over images and their storage format - basically a money grab by the MPEG group.

Having said that, I am aware that more images using this format will be sent my way.

Will you be implementing support for this format? I am not even sure about the licensing for image editor developers, of course.
/*---------------------------------------------*/
System: Win10 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), Nvidia GTX1080 8GB, Revodrive X2 240gb, e-mu 1820, 2XSamsung SA850 (2560*1440) and 1XHP2408H 1920*1200 portrait
User avatar
asharpe
Mitglied
Posts: 90
Joined: Mon 23 Dec 2013 07:01
Location: Palo Alto, California, USA

Re: Neue Testversion 20.90b8

Post by asharpe »

Martin Huber wrote: Wed 07 Mar 2018 10:36 You have turned on "View > Pixel Mode" and "View > Mark Extreme Values". Does turning off one or both of them change anything?
Well. Turning off View->Pixel Mode fixes the problem. What exactly is Pixel Mode? I'm sure I've never used it. Maybe I turned it on by mistake? Anyway, it's off now, and zooming in does just that, without any odd artifacts...
User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3893
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: Neue Testversion 20.90b8

Post by Gerhard Huber »

Herbert123 wrote: Wed 07 Mar 2018 21:16HEIF/HEIC image file
We don't plan a native support at the moment.
If you have the macOS PhotoLine, you can load such pictures, because macOS does.
Martin Huber
Entwickler
Entwickler
Posts: 3757
Joined: Tue 19 Nov 2002 15:49

Re: Neue Testversion 20.90b8

Post by Martin Huber »

asharpe wrote: Thu 08 Mar 2018 07:01
Martin Huber wrote: Wed 07 Mar 2018 10:36 You have turned on "View > Pixel Mode" and "View > Mark Extreme Values". Does turning off one or both of them change anything?
Well. Turning off View->Pixel Mode fixes the problem. What exactly is Pixel Mode?
In Pixel Mode PhotoLine renders the document at 100% at most.
But I can't reproduce the problem in Pixel Mode either, so im really interested in a sample document to reproduce and fix the problem.

Martin
User avatar
Herbert123
Mitglied
Posts: 1953
Joined: Sat 12 May 2012 21:38

Re: Neue Testversion 20.90b8

Post by Herbert123 »

Small Layers panel improvement request: when I select many items to group, and group them, it would be nice if the layer panel would automatically scroll to that new group. Currently I have to scroll up in the layers panel, because it doesn't keep track of where that new group is.

I always name my layers and groups, and having to scroll up all the time when I am organizing stuff in groups becomes very tedious.
/*---------------------------------------------*/
System: Win10 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), Nvidia GTX1080 8GB, Revodrive X2 240gb, e-mu 1820, 2XSamsung SA850 (2560*1440) and 1XHP2408H 1920*1200 portrait
User avatar
asharpe
Mitglied
Posts: 90
Joined: Mon 23 Dec 2013 07:01
Location: Palo Alto, California, USA

Re: Neue Testversion 20.90b8

Post by asharpe »

Martin Huber wrote: Thu 08 Mar 2018 10:23
asharpe wrote: Thu 08 Mar 2018 07:01
Martin Huber wrote: Wed 07 Mar 2018 10:36 You have turned on "View > Pixel Mode" and "View > Mark Extreme Values". Does turning off one or both of them change anything?
Well. Turning off View->Pixel Mode fixes the problem. What exactly is Pixel Mode?
In Pixel Mode PhotoLine renders the document at 100% at most.
But I can't reproduce the problem in Pixel Mode either, so im really interested in a sample document to reproduce and fix the problem.
Martin
Ok, I uploaded the DNG file to my web server. It's not a good example of my work, but it demonstrates the issue. I've tried other images, and they all show the problem in Pixel Mode. Here's the url. It's a full size original DNG file, so it's about 28MB: http://andrewsharpe.com/_K3_9749.DNG
Martin Huber
Entwickler
Entwickler
Posts: 3757
Joined: Tue 19 Nov 2002 15:49

Re: Neue Testversion 20.90b8

Post by Martin Huber »

asharpe wrote: Fri 09 Mar 2018 05:12Ok, I uploaded the DNG file to my web server. It's not a good example of my work, but it demonstrates the issue.
I can't reproduce the problem with this file either. Can you also send us your PhotoLine.xml located in "~/Library/Preferences/PhotoLine" by e-mail (or if you are using a PhotoLineSettings folder the PhotoLine.xml inside of that)? Maybe some combination of settings is producing the problem.

Martin
Martin Huber
Entwickler
Entwickler
Posts: 3757
Joined: Tue 19 Nov 2002 15:49

Re: Neue Testversion 20.90b8

Post by Martin Huber »

Herbert123 wrote: Fri 09 Mar 2018 01:38 Small Layers panel improvement request: when I select many items to group, and group them, it would be nice if the layer panel would automatically scroll to that new group. Currently I have to scroll up in the layers panel, because it doesn't keep track of where that new group is.
I have tried several ways of grouping now, and PhotoLine always selects the newly created group and makes it visible.
Do you have any additional advice how to reproduce the problem. Is maybe the search mode of the Layer List activated?

Martin
User avatar
Hoogo
Betatester
Posts: 3865
Joined: Sun 03 Jul 2005 13:35
Location: Mülheim/Ruhr

Re: Neue Testversion 20.90b8

Post by Hoogo »

I remember that once there were vertical lines because of a broken color profile.
Or something like that, the reason was quite unexpected, but I can't remember details.
----------------
Herr Doktor, ich bin mir ganz sicher, ich habe Atom! /Doctor, doctor, I'm sure, I've got atoms!
User avatar
Gerhard Huber
Entwickler
Entwickler
Posts: 3893
Joined: Mon 18 Nov 2002 15:30
Location: Bad Gögging

Re: Neue Testversion 20.90b8

Post by Gerhard Huber »

Hoogo wrote: Fri 09 Mar 2018 10:52 I remember that once there were vertical lines because of a broken color profile.
Or something like that, the reason was quite unexpected, but I can't remember details.
there is/was a problem with the "System" profile, when it was created with Windows. Setup the screen profile from "System" to "sRGB", is the problem gone?
Martin Huber
Entwickler
Entwickler
Posts: 3757
Joined: Tue 19 Nov 2002 15:49

Re: Neue Testversion 20.90b8

Post by Martin Huber »

Martin Huber wrote: Fri 09 Mar 2018 10:05
asharpe wrote: Fri 09 Mar 2018 05:12Ok, I uploaded the DNG file to my web server. It's not a good example of my work, but it demonstrates the issue.
I can't reproduce the problem with this file either.
I could reproduce the problem with one of my own pictures, so I am now able to examine the problem.

Follow up: The problem here only occurs if the document profile and the screen profile are the same. Does this match your situation?
IMO this is an error in macOS and I filed a bug report with them. We will additionally insert a fix in PhotoLine.

Martin